Installing Pfsense on disk issues



  • Hello

    Im encountering an issue during the process of:

    #Executing '/sbin/bsdlabel -B -r -w ad2s1 auto'

    The log follows with

    #bsdlabel: write /dev/ad2s1: Input/output error
    #Exit Status:1

    The machine is running with:
    motherboard: A7V8X-LA (Kelut)
    Processor: Amd Athlon XP 2600+
    Memory: 512MB / PC2700 DDR SDRAM x1
    Harddrive: wdd400 40gb Pata Hdd
    Nic: Intel PRO/1000 GT Desktop Adapter, PCI (PWLA8391GTBLK) x2

    I am using the:
    pfSense-LiveCD-2.1.3-RELEASE-i386-20140501-1552

    I Have tried multiple solutions found in this forum:

    • Low level formatting with Windows Disk Management (no problem)

    • formatting the disk via the disks custom install (no problem)

    • changing the Access mode of the hdd to CHS and LBA from auto (no problem)

    • running the following in the live cd's shell
              # dd if=/dev/zero of=/dev/ad0 bs=8k count=16
              # fdisk -I ad0
              ( I get errors :
              #dd: unknown operand of
              #fdisk: unable to get correct path for ad0: no such file or directory)

    I am sorry, if i missed a small detail and will do any of the methods i tried again as I am new to Pfsense and havent got any experience with FreeBSD



  • Update, after doing a multitude of trial and error (which will be listed at the bottom), i got it past the installation,through the reboot and on to configuring pf sense on my main computer. The last method i tried was placing the hard-drive into slave mode while having the disk reader as the master on the first channel of the motherboards pata controller. 1*

    I feel really stupid and confused on why or how this worked. I do not believe that it has anything to do with the jumpers on the devices (master, slave) nor do i believe that the access mode (LBA) has anything do do with it (maybe) because I tried multiple combinations of everything.

    on a side note: I switched installation dvds and burnt myself a copy of pfsense 2.1.4 i386, which did not also worked untill I did the change above.

    The changes that i made were (not in chronological order, also the ones i can remember)

    • reformatting and partitioning the drive via FreeBSD 8.3 i386 dvd (Errors when installing freebsd but partition and formats remained)

    • switching: Pata cables, sata and pata Harddrive, cd/dvd burners, memory

    • turning off: ps/2 mouse, onboard 1394, Serial ports, Parralel ports ,usb legacy mode support(which was turned back on)

    • installing windows xp(which the machine Had), and updating Bios as well as partitioning the disk

    • attempted to use pfsense live cd shell and try to learn fdisk to get a hint as to what the problem was

    edit: 1* as opposed to having both hard drive and disk reader be the master of their respective pata channels : hdd = channel 2 , Disk = channel 1


Log in to reply