Miniupnpd (UPnP Service) will not start: 2.1.4



  • Hello!

    I'm running 2.1.4 i386 and cannot get miniupnpd to start as a service.

    This is how I have Services > UPnP & NAT-PMP configured:

    After enabling it in the UI and clicking the Change button, it tells me the service has been started - but it never does start. If I click the start button from the UPnP settings screen, this is what shows:

    I've waited for 30 minutes and it still hasn't started. Status > System Logs will show this:

    I'm guessing this is user error. :o What am I not doing right? Thank you all in advance! :)

    Tony


  • Netgate Administrator

    The change that introduced lisening on interface rather than IP (and broke UPNP for many in 2.1.3) was done in order to support IPv6. Are you running IPv6? Try switching to listening on the interface.

    Steve



  • The miniupnpd version currently shipping with pfSense is not compiled with IPv6 support, so that shouldn't be it.



  • Interesting… Just upgraded a box to 2.1.4, and it seems that /var/etc/miniupnpd.conf never gets created?!

    EDIT: Sorry, had the wrong interface selected; seems to get created just fine now, and miniupnpd does start. (Error handling seems pretty much non-existent, though, other than messages in the system log...)



  • Hey thanks for the replies!

    I am not running IPv6 anywhere and have it disabled where I can. I enabled the "Listen on interface instead of interface's IPv4 address" setting, and still could not get the service to start.

    I performed a fresh install and the issue persists. Perhaps it's my hardware+drivers? What information can I provide?



    • Look in the system log for any miniupnpd-related entries.
    • In the console, do "ps auxww | grep miniupnpd".
    • If no miniupnpd process is found, do "/usr/local/sbin/miniupnpd -f /var/etc/miniupnpd.conf -P /var/run/miniupnpd.pid -d" and see what it says.

Log in to reply