Installer on APU1C4 ignores keybord input



  • Hi,

    this is wierd .. I'M trying to install my second APU1C4 (everything worked fine on the first one) and I'm banging my head against the wall … as soon as the installer reaches the point where you can either hit R for recovery or I for install it ignores any keyboard input.
    I can get into the first menu though (the one where you can break out to the console) if I connect a USB keyboard, it then times out and finally stops at the questions I want to set up VLANs.
    I tried 2.1.2, 2.1.3 and 2.1.4 images (e.g pfSense-memstick-serial-2.1.4-RELEASE-amd64-20140620-1259.img) as I want to use the 16GB mSATA card in the box.
    I don't think that it's a hardware fault, otherwise i could not go to the console, etc.
    I also tried several terminal emulators (ZOC, Putty, IVT VT220, Tera Term, etc.), does not change anything.
    Any ideas ? Any thoughts welcome!

    Cheers, Stefan


  • Rebel Alliance Developer Netgate

    Keyboard input from where? A USB keyboard or over serial?

    I/O on there should all be over serial via the terminal program. A USB keyboard would have zero effect on the APU.

    I've installed on my APU using the serial memstick several times, no issues at all.



  • Hi, I'm getting mad to try to create an usb stick installer. I tryed everything… win32disk, imgTools, several pendrives, winrar and 7-zip... nothing.

    I use pfSense-memstick-serial-2.1.4-RELEASE-i386.img but when when the process is finished on my pendrice I have just a small partition, 24mb, and nothing else.

    I wanted to setup on apu1c board... which version and process do you use?? the usb installer or nanoBSD image ???

    I wanted to use a SD card, 16GB.

    Thanks for any help...

    Andrea



  • Hi xandrea, i would suggest  Alexander Beug's USB Image Tool, it works great . At least, worked for me too !

    more details on the following post

    https://forum.pfsense.org/index.php?topic=28264.30

    According to the SD Card, you should use an embedded / nanoBSD image.

    Vassilis



  • I have a similar problem with my APU.

    Mine situation is where the keyboard works fine through putty when in the APU bios at 115,200.  But when I switch to 9,600 for PFsense it will not work at all meaning PFsense goes through all the booting but I cant input anything.

    Any suggestions to help me?



  • Hey @all,

    I had the same probleme.
    Solution: In PuTTy-Option "Serial" set "Flow Control" to "None" instead of the standard option "XON/XOFF"

    Hope someone could use this :-)