2 conexoes externas para o proxy squid 3


  • possuo duas conexões externas, uma é internet (velox) e a outra é uma intranet externa, quero mandar as duas redes pelo proxy squid.

    o servidor do pfsense tem 3 placas de redes, uma para o velox, uma para a intranet externa e a outra é de saida do proxy.

    o velox esta passando normal pelo proxy, só que a intranet externa nao funciona nem pinga, cada uma tem 1 gw e dns diferentes e quero passar tudo pelo proxy.


  • Amigo no squid3 nas opções de transparente você pode selecionar as 2 redes e se for squi3 interceptação de ssl marque as 2 também coloque caso use… lembrando que essas redes são esternas então vão te que trabalhar em um loadbalance se num me engano... Então terá que criar um grupo de load...


  • só queria saber como utilizar os 2 gw juntos, quando ativo um o outro para.


  • faça uma regra e fail over crie um grupo em roteamento com o gw principal com peso 1 e o gw2 peso 2 se voce for usar proxy te aconselho a verificar alguns tópicos no forum que fica até mais facil…. pesquise por fail-over ou failover....


  • amigão, fiz todas regras de failover e loadbalance que achei na internet/forum e não consegui fazer o que queria. Quando um funciona o outro link não funciona.(consegui fazer com outro servidor, mais quero fazer no pfsense), já baixei 3 versões diferentes do pfsense,ja restaurei varias vezes o servidor para refazer do zero seguindo as video-aulas e nada funcionou Vou explicar novamente o que quero fazer:

    possuo 2 links externos, um de internet(velox com ip 192.168.0.x) e outro é uma intranet(redes locais da empresa com ip 10.1.240.x) e quero passar as duas redes na terceira placa em um link que saia no ip 10.1.240.x, tenho 1 pc com o pfsense instalado e 3 placas de rede, não precisa nem ser por proxy pode ser direto mesmo.


  • @oreizinho:

    amigão, fiz todas regras de failover e loadbalance que achei na internet/forum e não consegui fazer o que queria. Quando um funciona o outro link não funciona.(consegui fazer com outro servidor, mais quero fazer no pfsense), já baixei 3 versões diferentes do pfsense,ja restaurei varias vezes o servidor para refazer do zero seguindo as video-aulas e nada funcionou Vou explicar novamente o que quero fazer:

    possuo 2 links externos, um de internet(velox com ip 192.168.0.x) e outro é uma intranet(redes locais da empresa com ip 10.1.240.x) e quero passar as duas redes na terceira placa em um link que saia no ip 10.1.240.x, tenho 1 pc com o pfsense instalado e 3 placas de rede, não precisa nem ser por proxy pode ser direto mesmo.

    Certinho amigo… Bom também tive problemas com proxy resolvi quebrando muito a cabeça mas até hj só consegui em uma maquina e mesmo restaurando o backup dela para outro server não funcionou, mas se for o loadbalance com 2 links sem proxy funciona sim....

    Na parte que voce disse que possui uma rede intranet rede local ela parte de um servidor linux com um webserver rodando?
    e apartir desse links voce quer que todos tenhão acesso a ele e também a net tudo junto ? Certo ?

    posso te passar umas regras aqui simplificadas....

    primeiro tenhas os dns prontos depois crie 2 grupos em "System: Gateway Groups" Sendo um de Loadbalance com Tier 1 e Tier 1, depois crie outro grupo com Tier 1 sendo esse o link principal e Tier 2 sendo o de FailOver.....

    após isso vá até "Firewall: Rules" e modifique seu regra de IPV4 para fica assim.....

    IPv4 * LAN net * * * LBFO none

    logo percebe que tenho ali em cima "LBFO" esse é para que tudo seje o loadbalance soma de links e redundancia mas agora vamos criar outra que ficará acima dessa....

    IPv4 TCP LAN net * * 443 (HTTPS) FO none

    pronto logo teremos uma regra que retira a porta 443 de load para não ter problemas com sites de bancos mas como vc usa um intranet creio que possa usar essa porta então crie regras para que o serviços que vc usa sai pelo load, assim

    IPv4 TCP * * youtube_e_google * LBFO none

    nessa criei Aliases para o youtube e google passarem no loadbalance assim download no maximo.....

    bom feito isso, deverá estar tudo ok
    lembrando que as regras são de cima para baixo assim crie as regras de load antes da que retira o https do load..

    tenta ai ve se funciona caso não te ajude deixa o maximo de informação para mais pessoas poder de ajuda....  :D