Rackable systems LCD display from OS



  • Hi all,
    I have a Rackable system from http://unixsurplus.com/products/rackable-servers?pagesize=40

    System works great and looks like it will make a fine pfSense box.

    But…just for the fun of it (and because "it's there") I've been trying to get the LCD to display some info.

    I can attach to the rackable systems "roamer" interface (via com cable/cat5 adapter) and change the display no problem.

    But according to a manual I found here http://tier2.ihepa.ufl.edu/archives/cms-t2/2006-09/msg00109/RoamerUserManual4.4.5.pdf

    I should be able to print messages directly to the LCD from the OS…..maybe

    "Note that the execution environment must have access to the serial port in order for this scripting to work. In the very common
    situation where agetty is running on the serial port (as a login prompt on the port), agetty locks the serial port and does not
    allow access by other programs. To get around this, try performing any LCD programming before agetty is launched (usually by
    init/inittab) in a startup rc.d file. This is generally done in rc.local under Red Hat Linux, or boot.local under SuSE Linux. Either
    file can be found in /etc/rc.d/."

    Does it sound like this could be done w/pfSense....or is this just going to be more trouble than it's worth??
    What is psSense's default com port ?
    i looked under /dev/  but didn't see any ttyS1, and the /ectc/ttys file is a bit confusing ...
    Has anyone done this already, or could you steer me in the right direction?

    Thanks,

    -S


  • Netgate Administrator

    I have skimmed the manual. So the LCD is connected to the Roamer module and not to the motherboard directly?

    The default serial console, if it's enabled, is on the lowest serial port usually /dev/cuau0.

    Steve



  • Correct, the LCD is connected to the roamer board (Appendix 1 in the manual ) via a flat white ribbon cable (to the LCD connect terminal–ribbon cable connector).

    the IO jack on the front of the rackable face plate seems to be connected to the "external serial" connector on the board, and the  "serial to MB std" connector appears to be connected to the motherboard.

    http://download.intel.com/support/motherboards/server/sb/d36217006_s5000psl_userguide.pdf

    under "connector and header locations" it is connected to "SS. Serial B / emergency management port header"

    So I'm guessing that when I connect to the front IO jack I'm really just "passing thru" the roamer board via the external serial connection, and being passed to the MB from the "serial to MB std" connector.

    So…it looks like that may be serial port 2 ??
    I tried both  /dev/cuau0 and  /dev/cuau1 ...... no joy

    -S


  • Netgate Administrator

    OK. So when you connect to the RJ45 console connector do you see thee pfSense console menu or the Roamer menu?

    Steve



  • Roamer menu.
    …Hummmm.....yea....so not a straight pass thru......

    dmsg.boot output>>>

    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    uart0: [FILTER]
    uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
    uart1: [FILTER]
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 900
    pmtimer0 on isa0

    Tried uart0-1 … no joy..</high>


  • Netgate Administrator

    What exactly are you trying?

    Assuming you are running a full install there isn't a serial console unless you've enabled it in System: Advanced: Admin Access:
    With that enabled I would expect to see it via the RJ45 port since the roamer module should start up in pass-through mode.
    To use the LCD from pfSense it looks like you need to put the roamer module in shell mode and then talk to it using  cu.

    Steve


Log in to reply