• hi i 'm trying to make squid3-dev working on a pfsense 2.1.4 release (amd64)  i need transparent proxy with ssl interception

    first it had work nicely exept https interception then without any modification squid crash at start with this message :

    pf php: /pkg_edit.php: The command '/usr/pbi/squid-amd64/sbin/squid -k reconfigure -f /usr/pbi/squid-amd64/etc/squid/squid.conf' returned exit code '1', the output was 'squid: ERROR: No running copy' 
    

    i  try to delete squid3-dev package and re- install it with same result, anyone getting same problem or can help me to resolve that ?

    can i do https interception with squid 2-7-9 version avalaible in package ?

    thanks


  • Well, you're getting farther than I am.  I'm still stuck with all HTTPS sites giving the browser a Cert warning, even though I've imported the pfSense CA as a Trusted Root, and the Server cert.  Still I get browser cert errors.

    To answer your question, no.  You need Squid3-dev to do SSL filtering.


  • Same Here
    and squidgurd wont be uninstsall
    if you uninstall squidgurd it will stay in sevice >> poxy filter
    click on it lead you to error page


  • I figure out good solution

    First uninstall squid3-dev (and squidguard if any)
    then
    install  squid3    (3.1.20 pkg 2.1.0)
    then uninstall squid 3

    finally install  squid3-dev

    tm make squidguard work with squid3-dev
    you should flow this steps
    https://forum.pfsense.org/index.php?topic=73640.0