DNS Forwarder error



  • Hello Forum,
    I am trying to redirect www.google.com(74.125.236.177) to www.safesearchlive.com(74.208.25.104) using Host Override option in DNS Forwarder. When I try to redirect the website to safesearch.com it is giving 404 error. But if I change the IP address of host to some other website for e.g: www.microsoft.com(134.170.184.133) it is redirecting perfectly. What might be the possible error?


  • Rebel Alliance Global Moderator

    they use host host headers..  Just try calling up the IP directly..  They don't serve the page unless you send the host head of the name..



  • @johnpoz:

    they use host host headers..  Just try calling up the IP directly..  They don't serve the page unless you send the host head of the name..

    Do I need to make use of Varnish package to forward based on the host headers or is their any other alternative?
    And I'm sorry sir I did not get what you meant by calling up IP directly. Can you be more specific?


  • Rebel Alliance Global Moderator

    http://74.208.25.104

    Doesn't work because they don't serve up anything off that IP..

    https://support.google.com/websearch/answer/186669?hl=en
    The proper way to enforce using google safesearch is to enable to append &safe=active with a proxy

    Unless your locking it on the computer itself

    What exactly are you trying to accomplish?

    To enable SafeSearch throughout a school network, you’ll also need to use a a proxy server to append &safe=active directly to all search URLs.



  • @johnpoz:

    https://support.google.com/websearch/answer/186669?hl=en
    The proper way to enforce using google safesearch is to enable to append &safe=active with a proxy

    Unless your locking it on the computer itself

    What exactly are you trying to accomplish?

    To enable SafeSearch throughout a school network, you’ll also need to use a a proxy server to append &safe=active directly to all search URLs.

    I am using Squid proxy and Squidguard and their is any option to enforce safesearch in Squidguard. Even though I check the option for safesearch its not getting reflected. I want block the adult content images from the search engines. I was successful in blocking the websites but images are getting loaded.

    When the school students browse for the content related to their subjects for example images for satellites I want those images to be loaded. But, if they search for adult content such as porn images, those images should be blocked.

    How can I achieve that?


  • Rebel Alliance Global Moderator

    And are you appending what they suggest?  Say something like?

    something like
    regexi ^(http://www.google../search?.) \1&safe=active
    regexi ^(http://www.google../images?.) \1&safe=active

    to do the rewrite of the url?

    Are you blocking https searches?



  • @johnpoz:

    And are you appending what they suggest?  Say something like?

    something like
    regexi ^(http://www.google../search?.) \1&safe=active
    regexi ^(http://www.google../images?.) \1&safe=active

    to do the rewrite of the url?

    I used the above mentioned regular expression in rewrite option available in Services->Proxy Filter, but the result is same. Safe search was not enabled in google.

    @johnpoz:

    Are you blocking https searches?

    I have enabled SSL filtering option in Proxy server and due to which every HTTPS website gets blocked. So I added www.google.com to the whitelist and tried to redirect it using rewrite option as well as DNS forwarder and the result is still the same i.e No redirection and No safesearch enabling.