Sarg work around



  • I have managed to install squid + squidGuard ( offtopic: still having some issues with squid redirect errors)
    so i continued with installing sarg in order to get reports .

    While i was able to configure correctly Sarg and it's schedule and forced the update too. I still had some problems.
    The reports where not being displayed issuing some error BUT the realtime tab was working.

    So i did a little research to fix this out, seems like that sarg creates the report files in

    /usr/pbi/sarg-i386/local/sarg-reports/
    

    but for some reason in order to view the report from Sarg Reports->View Report
    the report files must be present in the following directory

    /usr/local/sarg-reports
    

    So what i did to solve this issue was:

    1. rm -r /usr/local/sarg-reports
    2. ln -s /usr/pbi/sarg-i386/local/sarg-reports /usr/local/sarg-reports

    Eventually i can read the report files from the report tab inside Sarg.
    Hope it helps.

    P.S.1 this fix is only for i386 build

    P.S.2 NEEDS FIX. every time the scheduler starts it creates a new report file

    07Jul2014-07Jul2014
    07Jul2014-07Jul2014.1
    07Jul2014-07Jul2014.2

    i dont know how to fix this, the command i use into the scheduler is

    -d `date +%d/%m/%Y`
    

    Update1 i enabled "Overwrite Report(NO)" from General->Report Options