[Solved] New ESXi install, can't get DHCP or any connectivity on LAN.



  • For the sake of just getting this working I'm only using the two integrated NICs on this ESXi v5.5 host.

    NIC0 = LAN & ESXi Management
    NIC1 = WAN

    I went through the usual ESXi pfSense configuration and install, which I've done plenty of times before.  I do not have the NICs mixed up in ESXi or pfSense, checked this about 100 times to be sure.  I even compared virtual MAC addresses to confirm.

    If I set my laptop to a static IP on the same subnet as the ESXi host I can access the host via the vSphere client and configure pfSense.  Once configured I can see that WAN is getting DHCP from the cable modem, and that the LAN has a static IP/24.

    If I set my laptop's IP to something in the subnet of pfSense LAN, I can not ping it or access web configuration.  If I set my laptop to DHCP it fails to see or get anything from the DHCP server, which in this case should be pfSense.

    I have never had this problem before, and unlike all my other ESXi/firebox/etc pfSense installs this current one is for work and I need to get this working fast because I'm trying to sell my bosses on the use of pfSense and so far they're not impressed. :(

    EDIT:  I am not setting a gateway on LAN, and I've tried both my own static LAN IP and the default LAN IP during the initial pfSense CLI configuration.

    EDIT2:  I'm using the "pfSense-LiveCD-2.1.4-RELEASE-i386-20140620-1259" install.  The host is a dual Xeon x6 server with 16GB RAM and 2x integrated Gb NIC.  ESXi is version 5.5



  • Went ahead and did a fresh install of ESXi v5.5 on that server which I'll follow up with a fresh install of pfSense 32bit.  Will report back in a few with the results.

    I also installed a brand new Intel gigabit PCI NIC.  The plan is to have…

    NIC0 - Management
    NIC1 - WAN
    NIC2 - LAN(PCI NIC)



  • Reinstalling both appeared to work and I got in to the web config finally, but had no WAN…when I did the initial CLI configuration via vSphere I didn't have the modem plugged in because I didn't know what caused the problem on the first install.

    Plugged in the modem, verified proper configuration of both integrated NICs, tried a release/renew in web config, nothing.

    Rebooted pfSense, still no DHCP from the modem.  Did a release/renew in web config, still no DHCP from the modem.  Was working fine before the reinstall. :\

    Host doesn't see PCI NIC, but that's another problem for another day.



  • Rebooted modem, everything seems to be working now.