Squid Proxy Not Creating Logs? SARG & Lightsquid failing.



  • Hey guys, I just installed pfSense today and have been trying to get everything set up and am running into some issues with Sarg (and Lightsquid for that matter).

    I'm trying to get Sarg and Lightsquid to generate reports from Squid proxy, but for some reason they're both having trouble.

    Sarg gives me an error:

    [ Sarg config error: squid log file (/var/squid/logs/access.log) does not exists]

    and Lightsquid gives me the error:

    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)

    For Lightsquid, I tried clicking both "Refresh now" and "Refresh full" but still got the same error. For Sarg I checked /var/squid/logs/ and there is only one file - cache.log

    Is there something I haven't configured correctly with Squid, or anyone experience and solve these issues in the past? Any help would be greatly appreciated!



  • Are you using Squid2 or 3?  Can you verify that Squid is running properly?  How long have you been loading pages?  Lightsquid needs some time and traffic before it generates its first report, IIRC.  Make sure the Settings page is properly configured, then hit the Refresh Now button.  If the report is stil missing, make sure you refresh your browser with a ctrl-F5.



  • I believe Squid 2, assuming that's the plain "squid" package as I selected that one over the "squid3" package since I didn't want to use beta packages for now.

    I believe it is running properly as I saw a bunch of logs in the cache.log file. Also, it seems to cause some websites to time out occasionally, like Amazon and SlickDeals, and shows a page about not being able to connect with the Squid package name at the bottom of the page. Is there any other way I should confirm it's running properly or specific settings I should change?

    I had only been loading pages for probably an hour or two, though I was mostly just searching forums and modifying things on the pfSense GUI since I just installed it last night, so maybe I need to wait for much more traffic, though the fact that squid keeps making some websites timeout leads me to believe I have some other Squid issue as well.

    I did the reload now button and refreshed the page but no luck.



  • Do you have Squid's logging set to enabled and the Log store directory set to its default of /var/squid/logs?



  • Sorry it took me some time to get back to you. Wasn't able to check until after work.

    I feel pretty stupid… The "enable logging" option was un-checked, though the default logging directory is set properly. I thought I had checked that off, but apparently not. I will browse the web a bit and see if I can get some logs and charts!



  • Hm that seems to have fixed my SARG report issue (after I forced it to update the report), but the Lightsquid report is still showing the

    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)

    error.

    Any ideas?

    I already tried the suggestions here (https://forum.pfsense.org/index.php/topic,38442.msg198861.html) but it said that package perl-5.12.3 isn't installed so I assume this advice is outdated.



  • Could be your browser cache is retaining stale data.  Try to force a reload with Ctrl-F5.  A regular F5 isn't good enough.



  • I actually checked again last night after I hooked up my pfSense router to a wireless router setup to function as a wireless AP and it seemed to be working!

    I'm honestly not sure what changed or why it started working randomly besides me turning off Snort's auto-blocking feature, but I doubt that is related. At any rate, thanks for your help  :)



  • I suspect it was your browser cache.  I've seen this exact problem myself more than once, and a ctrl-F5 always fixed it.  You get the error page, hit F5 and see the same error page, hit ctrl-F5 and there it is.  It's weird like that, but you just remember the glitch if you do a lot of installs.