Queda de conexão ao habilitar a Lan



  • Prezados,

    Eu sou novo no uso do pfsense e estou com uma dúvida se puderem me ajudar eu ficarei grato.

    Eu instalei o pfsense no vmvirtualbox conforme um tutorial que encontrei na net, o pfsense está funcionando blz na máquina que hospeda a vm, ou seja, eu consigo entrar via browser do programa, efetuar as configurações necessárias e consigo pingar o ip do pfsense.

    Contudo quando habilito a Lan no PFsense minha conexão cai e não consigo mais acessar nem pela minha maquina nem pela vm .

    A placas de rede no PFSense foram configuradas da seguinte forma :
    Adaptador 1 : Modo Bridge
    Adaptador 2 : Exclusiva do Hospedeiro VistualBox

    Quando habilito a wan como em0 no console do pfsense ele pega o ip da net corretamente via dhcp e depois acesso ele via browser perfeitamente , como disse acesso tanto pela minha maquina como pela virtual que tem o Ubuntu instalado.

    Basta habilitar a Lan que cai a conexão e não consigo mais acessar de forma alguma

    Ouvi disser que o Ubuntu na VM tinha que estar configurado com adaptador 1 igual ao adaptador 2 do PFsense, mais fazendo isso não consigo navegar , ele só navega se for em  modo bridge , pois o que quero fazer é que essas maquinas virtuais usem o PFSense como Firewall , mais como falei ao habilitar a Lan cai tudo.

    O que falta eu configurar ou o que estou fazendo errado?

    Desde já agradeço a todos.



  • faça isso que vai funcionar

    Adaptador 1 : Modo Bridge -> recebendo link de internet
    Adaptador 2 : Modo Bridge -> com ip da sua lan que será o seu novo gateway

    o virtualbox cria uma interface virtual em seu hospedeiro, se vc quer usar a opcao de interface Exclusiva do Hospedeiro VistualBox vc precisa configurar o ip nessa interface virtual criada na mesma faixa que o pfsense vai criar na lan



  • caro lucaspolli grato pela atenção desde já

    Então cara eu fiz isso +- isso mesmo
    Minha interface exclusiva do VirtualBox esta configurada com 192.168.56.1 255.255.255.0 que é o ip que a minha internet local( NetVirtua ) disponibilizou pra ela, ai consequentemente na Lan no PFsense configurei na mesma faixa 192.168.56.2 porém como falei ao habilitar a Lan a conexão cai e não acesso mais, já no Ubuntu eu fiz a mesma coisa coloquei ele no ip 192.168.56.3 com GW 192.168.56.2  e além de não navegar ele não acessa internet e nem acessa o PFSense, pois perco todas as conexões.

    Ouvi disser que antes de habilitar a interface Lan no PF eu tenho que criar uma regra em Firewall- Rules permitindo passar tudo pela Lan senão não terei conexão mais e ai sim habilitar a interface..

    Vlw



  • esse é o problema.. vc nao pode ter os dois ips na mesma faixa… a wan tem que ser o ip fornecido pela virtua.. ou dhcp do modem deles diferente da sua lan..
    e a lan... qqer faixa... no seu caso a 56.0
    as interfaces do hospedeiro, seu linux no caso, nao podem ter o ip igual do pfsense... mesmo sendo em modo bridge a interface tem um ip e a virtual tm outro..



  • então acho que me expliquei errado ou não entendi sua colocação ..
    Minha Wan do PF pegou 192.168.0.20 que foi sim fornecido pela provedora
    o Adaptador 2 que é a  VirtualBox configurei 192.168.56.2

    Já aminha  placa da vm ela recebeu o ip 192.168.56.1 automatico , por isso coloquei o ubuntu como 192.168.56.3 e gw 192.168.56.2 para ele sair pelo PF, feito isso vou la e habilito a Lan no PF  e acontece o que te expliquei anteriormente..

    PS -  Ouvi disser que antes de habilitar a interface Lan no PF eu tenho que criar uma regra em Firewall- Rules permitindo passar tudo pela Lan senão não terei conexão mais e ai sim habilitar a interface..  PROCEDE ?



  • esse é so um ambiente de testes correto? deixe o pfsense como esta e a placa vm tb, no ubuntu deixe o ip da sua lan "oficial" e altere somente o gateway para o ip do pfsense… acredito que assim vai funcionar...

    ta meio confuso esse seu ambiente... vc quer rodar uma virtual com pfsense e fazer a fisica navegar usando como gateway a virtual.. isso tudo no mesmo equipamento.. rsrsrs
    vc pode subir mais uma virtual ao lado do pfsense e configurar as opcoes de rede.. creio que vai ficar mais facil..



  • exato apenas teste..

    então não é isso que quero não, apenas queria que os "  Ubuntu, Windows 7 , Xp , Freenas " ou maquinas virtuais criadas dentro da VM usassem o PF que tbm esta dentro da VM como Firewall entendeu , ao navegar pela net de alguns desses que citei ele usasse o pf, com isso farias meus laboratórios nele antes de colocar em produção aonde trabalho.



  • legal agora ficou mais claro…

    entao vamos la

    Maquina fisica (hospedeira das vms):
    Adaptador virtual : Exclusiva do Hospedeiro VistualBox -> ip 192.168.56.1 (ip e mascara, sem gateway)

    Pfsense:
    Adaptador 1 WAN : Modo Bridge -> ip da internet
    Adaptador 2 LAN : Exclusiva do Hospedeiro VistualBox -> ip 192.168.56.2

    Ubuntu:
    Adaptador 1 LAN : Exclusiva do Hospedeiro VistualBox -> ip 192.168.56.3 -> gateway e dns 192.168.56.2

    as duas virtuais (pfsense e ubuntu) irao usar a mesma interface virtual criada pelo virtualbox como "rota"



  • Exato cara é assim mesmo que as deixei

    Minha Maquina Fisica com o ip da net 192.168.0.18 mask 255.255.255.0 gw 192.168.0.1
    No adaptador virtual esta como 192.168.56.1 porém com mask 255.255.255.0

    PFSense
    Adaptador 1 WAN : Modo Bridge -> ip da internet 192.168.0.20
    Adaptador 2 LAN : Exclusiva do Hospedeiro VistualBox -> ip 192.168.56.2

    Ubuntu:
    Adaptador 1 LAN : Exclusiva do Hospedeiro VistualBox -> ip 192.168.56.3 ->  gw 192.168.56.2  , só não tinha colocado dns 192.168.56.2 como vc citou vou fazer o teste ..

    Porém entra aquele detalhe quando habilito a interface Lan eu perco a conexão com o PF de todas as formas, e ai ouvi disse aquilo que te perguntei de criar a regra antes de habilitar a lan se procede ?

    Porém 2 se eu deixo o Ubuntu como Adaptador 1 LAN : Exclusiva do Hospedeiro VistualBox seja DHCP ou Manual ele nem navegar não navega.



  • nao sei dessa regra…
    deveria estar funcionando..


Locked