PFSENSE +SQUID+SQUIDGUARD LENTO COM + DE 1000 USUÁRIOS



  • Olá a todos!
    Estou quebrando a cabeça faz algum tempo com o PFSENSE tentando achar uma solução, entrei nesse forum com a esperança de conseguir uma ajuda para resolver esse problema.

    O problema é o seguinte: Estou utilizando o PFSENSE versão 2.1.3, squid3 +squidguard em um ambiente com mais de 1000 usuários autenticando no AD. Utilizo a Shalla's Blacklists para fazer os bloqueios, tenho 5 grupos de usuários no AD. Chego muito cedo na empresa e tudo funciona bem, a medida que os usuários vão chegando para trabalhar a performance começa a cair e quando chega por volta das 10:00hs o Proxy praticamente para, a navegação fica extremamente lenta ou caindo, só consigo navegar se parar o serviço do squidguard.

    Já reinstalei o pfsense separando as partições /var e /usr e habilitando o soft-updates, vi alguma coisa de Tunning e tentei e até agora nada. Faço testes em servidores físicos e virtuais, coloco sempre 8GB de ram + 6 processadores de 3ghz.

    Deixei de lado a Shalla's Blacklist e fiz alguns bloqueios pontuais e mesmo assim o problema ocorre. Tive que deixar tudo liberado até arrumar uma solução.

    Será que o PFSENSE+SQUID+SQUIDGUARD suporta trabalhar com mais de 1000 usuários?

    Agradeço a ajuda de vocês.



  • Bom dia Marcio,

    Eu tenho um servidor dedicado para proxy com squid3 e squidguard3 com Shalla's Blacklist e fiz essa parte de partições e outros Tunning. Possuo na minha rede 3500 usuários, em torno de 1500 simultaneos. Autenticando no A.D. (NTLM-Kerberos-Winbind). Tudo normal.

    Não tenho nenhuma idéia do que seja, pois sem o squidguard não da problema. Se tiver mais detalhes (processamento, memoria. etc.. antes e depois do squidguard).

    abraços,

    att,

    Bruno Pinheiro



  • mcpmarcio você esta utilizando o path para deixa o squidguard sem ser sobre demanda?
    Pq o squid3 com o squidguard na ultima versão funciona sobre demanda, o squidguard so inicializa quando tem conexão.
    Caso tiver aplicado o path para sempre deixar o squidguard online, favor posta um print da GUI do squid3 para nos verificar-mos.



  • Olá!

    Será que o seu problema não é com autenticação?

    Se o Squid está autenticando os usuários, ele já encaminha o ID do usuário autenticado para o SquidGuard, então se você está filtrando por IP e não por ID, já causa alguma lentidão.

    Faça o seguinte, analise os Log do Sistema e também do SquidGuard. Em Proxy Filter, vá em Log e GUI Filter Log, Config Log.

    Em /var/squidguard/log verifique se o block.log também não está muito grande. Se estiver, "renove" o log, ele vai renomear o block.log para block.log.0, para fazer isso digite "squid -k rotate" sem as aspas.



  • O meu PFSENSE esta voando agora, antes estava rodando em uma VM criada através do XenServer, já tinha habilitado o soft-updates e tudo mais, mas o desempenho não era satisfatório.

    Coloquei para rodar em um servidor físico Dell com dois processadores Six Core de 2.4ghz, com os discos em raid1 e 8GB de memória RAM. Habilitei o soft-updates nas partições /usr e /var, fiz ajustes no cache, e criei também um LAGG Ports. O PFSENSE está excelente, estou muito satifeito com o desempenho. O meu parque tem aproximadamente 2500 computadores e chega a 1400 conexões simultâneas.

    Estou utilizando o squidguard e tenho 5 grupos de perfil de acesso com autenticação pelo AD.

    Obrigado!



  • @Bruno:

    Bom dia Marcio,

    Eu tenho um servidor dedicado para proxy com squid3 e squidguard3 com Shalla's Blacklist e fiz essa parte de partições e outros Tunning. Possuo na minha rede 3500 usuários, em torno de 1500 simultaneos. Autenticando no A.D. (NTLM-Kerberos-Winbind). Tudo normal.

    Não tenho nenhuma idéia do que seja, pois sem o squidguard não da problema. Se tiver mais detalhes (processamento, memoria. etc.. antes e depois do squidguard).

    abraços,

    att,

    Bruno Pinheiro

    Bom dia,

    Estamos com squid3 +squidguard + Autentificação no AD, onde estamos tendo o seguinte problema a performasse fica normal até um certo periodo, ao  fica lento reinicio o serviço proxy server filtre ai volta normal, alguém possa ajudar o que possa ser?

    Atenciosamente.



  • Melhor criar um tópico especifico para o seu problema, também com mais informações, como versão do pfSense e dos pacotes que está usando, topologia da rede, enfim.



  • Pessoal, estou com o mesmo problema ! Vou abrir um tópico com detalhes sobre o problema.



  • Aumentou a quantidade de helpers do squidguard?
    Já pensou em usar um pool de proxies para atender a essa demanda de usuários?


Log in to reply