[SOLVED] Adtran > PfSense > LAN



  • So it's late. I'm struggling to get this going and hope that someone can help so I can finish this another night.

    I'm trying to replace an old SonicWALL firewall that is in place with pfSense, but am having trouble getting it to cooperate with my current adtran router. (IPs are not accurate, but get the point across)

    Basically the setup is this:
    Adtran: 63.55.123.129/27
    Current Firewall 63.55.123.130/27
    LAN: 192.168.1.0/24

    The current firewall has the current configuration on it:
    WAN Gateway (Router) Address: 63.55.123.129
    SonicWALL WAN IP (NAT Public) Address: 63.55.123.130
    WAN/DMZ Subnet Mask: 255.255.255.224

    I have the WAN IP address in pfSense configure as 63.55.123.130/27
    I've tried setting the upstream gateway to both: (none) and 63.55.123.129 without any luck.

    Am I missing something. From my understanding with a single WAN interface, pfSense will automatically configure NAT.

    I just can't get this thing up and running. I can hit the LAN & WAN IP of pfSense, but after that, nothing.

    Any help/guidance would be appreciated. Thanks in advance.



  • Yes, it should just work.  Are you using 2.1.4, or something older?  i386 or amd64?  Dedicated hardware, PC or virtual?



  • Currently on 2.1.4. amd64. Dedicated hardware.
    I'm running a mini-box with an Intel Atom (D2500CCE) dual onboard NICs.

    I kept going at it last night, but still could not get it going.  :-\



  • Can you ping the pfSense WAN port from the Adtran and vice-versa?  If the Adtran is a DHCP server, you could try setting you pfSense WAN to DHCP and see what happens.  You 'aren't going to have much luck setting your upstream gateway to 'none'.  There may also be an auto-negotiation issue.  Go to Interfaces - WAN and then manually set the proper link speed & duplex mode.



  • Errr. Our router is managed by our ISP, so I am not able to log into it (I hate this). I'll have to get someone on the phone to troubleshoot with, unfortunatly. I will try again tonight and make sure to manually set link speed & duplex mode. I'm sure I'm missing something simple. I read somewhere else to uncheck the "Block Private Networks" option. I'm also curious if it's not actually a /27 and instead a /28. I don't remember having that many IPs, but the SonicWALL is currently set at /27. Odd.

    If anyone else has any other ideas that would shorten my night, I would appreciate it! Thanks a lot KOM. I'll be sure to post my findings later tonight.

    I shouldn't have to create virtual IPs for the WAN IP or the upsteam gateway, should I?



  • Setting the gateway to the ip address of the Adtran (63.55.123.129) looks like a normal value to me.
    When I changed the router/firewall at work I also had to reboot the modem (router in bridge mode) for an unknown reason,
    but it only worked after rebooting.
    You can uncheck the 'Block Private Networks' in the interfaces->WAN options
    If it doesn't work I would also try to set the mac address of the old router in the wan options.



  • I was thinking about bouncing the router this morning. It might still have the old firewall in it's ARP table. I'm feeling really hopeful tonight. Thanks.



  • Just wanted to thank both of you for your help. I was able to get everything up and running tonight!

    After I had configured everything, I was still having no luck. I bounced the router and a switch and still nothing. I then decided to try to reboot the pfSense box and wallah! It all worked. Everything is in place and THANK YOU for taking your time to help me out!



  • Glad to hear you got it working.