SQUID CACHE com Traffic Shaper



  • Implementei um servidor com o pfSense em minha rede utilizando os serviços do SQUID Cache (utilizo o cache do squid) com o QoS Traffic Shaper mais notei que mesmo os arquivos estando em cache eles passam pelo Traffic Shaper
    Eu gostaria de criar uma regra que se o arquivo estiver em cache não seja filtrado pelo Traffic Shaper, ou seja, o computador cliente que estiver fazendo esse download (em cache) não deve passar pelo QoS
    Já tentei criar essa regra em Rules/Floating mais não funcionou. Alguem sabe como fazer isso ou se isso é possível?



  • Boa noite Guiuliano,

    Filtrar os arquivos de cache você não vai conseguir, pois o qos (layer 2) trabalha numa camada inferior a camada de proxy (layer 7) baseado no modelo de referencia OSI. Com o QOS voce poderia desmarcar a prioridade para o trafego do proxy, fazendo com que todo trafego cliente proxy não tenha prioridade.

    Posso estar enganado, mas acho que seu problema poderia ser tratado com delay_pool em vez de Traffic Shaper. Post mais informações a respeito de seus objetivos e seu cenário.

    aguardamos,

    att,

    Bruno Pinheiro



  • OK Bruno, entendi

    vou estudar mais sobre o delay_pool

    muito obrigado pela ajuda



  • Disponha, assim que tiver um compreensão melhor sobre o assunto e surgir duvidas, pode postar aqui.

    • No caso do delay_pool, voce faria as configurações em "Services > Proxy Server > General > Custom Settings > Custom Options"

    abraços.

    att,

    Bruno Pinheiro



  • O Delay Pools não seria na aba Proxy server: Traffic management?



  • @Tomas:

    O Delay Pools não seria na aba Proxy server: Traffic management?

    Isso mesmo Tomas, mas é bem simples. Onde tenho limite por hosts e não por grupo de hosts. É muito útil, eu utilizo este, somente quando tenho um cenário critico ou com muitas especificidades, que faço na mão.

    att,

    Bruno Pinheiro.



  • Há sim, uso esse também, achei que tinha alguma coisa que eu não estava fazendo direito.

    Aproveitando Bruno, aqui tenho uma situação estranha que já acontecia com Squid 3 rodando em Linux.
    Não sei tem o mesmo com você;
    Por exemplo eu configuro 200 por host e na pratica da algo próximo de 100, ficando por volta de 95 a 97.
    Tem ideia do que possa ser?

    Obrigado.



  • Olá Tomas,

    então, esse valor definido em "Services > Proxy server > Traffic Mgmt > Squid Traffic Managment Settings > Per-host throttling" é da unidade de medida Kilobyte (multiplo do byte *1024). No squid.conf - delay_pool ele é adicionado em byte. No seu caso como adicionou 200, no seu squid.conf deve estar assim 204800.

    Veja que na hora dos testes o valor tem que ficar variando por volta de 200.

    Não sei por que seu download ficou baixo, verifique se a unidade de medida que aparece no momento do download é KB. Tente baixar de um servidor que não limite estrangule o download.

    http://centos.secrel.com.br/7.0.1406/isos/x86_64/CentOS-7.0-1406-x86_64-DVD.iso

    att,

    Bruno Pinheiro.



  • Então, no arquivo de configuração está mesmo 204800, mas já testei de várias formas, com vários tipos de arquivo.
    E não da o valor, mesmo quando antes usava Squid 3 com Debian.

    E isso em link diferentes, não sei se tem alguma coisa que eu estou esquecendo de ver.



  • Não era pra ter nada a mais que isso, faz assim, no terminal executa um```
    squid -k reconfigure

    
    att,
    
    Bruno Pinheiro.


  • Não da erro, já tinha testado.
    Eu tenho usado assim, e defino mais ou menos o dobro do valor e aí fica dentro do que preciso.
    Nunca consegui resolver isso.



  • Estranho. verifica se está mais ou menos nesse padrão o seu squid.conf:

    quick_abort_min 0 KB
    quick_abort_max 0 KB
    request_body_max_size 0 KB
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 -1/-1 512000/512000
    delay_initial_bucket_level 100
    delay_access 1 allow allsrc

    Não considere o 512000.

    Se deixar sem valou definido (delay_nao_definido), a banda ultrapassa valores maior que o definido anteriomente?

    Se possivel suba um proxy em paralelo a esse e faça um teste de um unico host isolado dos outros.

    No mais só analisando o squid.conf, mas acho que não tem nada la.

    att,

    Bruno Pinheiro



  • Está tudo no padrão.
    Já testei de todos os modos. Com -1/-1 ou com outro valor e nada.
    Vou fazer mais testes.