Is it by default that port:80 traffic is being dropped by pfsense?



  • i've setup a basic network but I can't view/browse a local http server running at default port 80.
    Telnet-ing to http server (telnet ip.add.re.ss 80) works, telling me that web service is running.

    what could be that i missed?

    (Since no one replied, this is the short cut version of my previous post ;). i hope that the admins would consider this. )



  • You mention that this is a local http server. Is the pfSense firewall, your http server and the client in the same IP range? All three have for example an IP address in 192.168.1.x? If that's the case, then the traffic does not pass through the pfSense firewall, and it can't be that one that's blocking.



  • i can ssh from a client to http server with no glitch.
    I can telnet to the http server with no issue as well.
    i can ping the http server with no issue as well.
    "but" if i try to view the index page of the http server it won't display. Instead the url changes from http://192.168.1.10 (after pressing enter key, the url changes to) http://192.168.1.10:4444)

    *** where :4444 is the external port used in the DNAT settings.
    additional information, that http server is viewable through DNAT with no issue. DNAT just works.
    http://ex.ter.nal.ip:4444 ===dnat===>http://192.168.1.10:80

    perdong



  • Have you tried another browser? What web application is it? Could be that the web application expects the URL to contain port 4444, or something along those lines. When it doesn't see :4444, it sends a redirect where the URL contains :4444.



  • @local network:

    [2.1.4-RELEASE][admin@pfs.mydomain.org]/root(5): telnet web.mydomain.org 80
    Trying 192.168.11.10...
    Connected to web.mydomain.org.
    Escape character is '^]'.
    ^C
    

    @public network:

    $ telnet ex.ter.nal.ip 4444
    Trying ex.ter.nal.ip ...
    Connected to ex.ter.nal.ip .
    Escape character is '^]'.
    

    so i was expecting that I will be able to browse locally with no problem, but it was the reciprocal. :(

    http server has a simple page phpinfo.php running on Apache2 with php5.x.



  • A real challenge :) Are you using a http proxy in your web browser?

    If both your client and http server are on the same broadcast domain (same subnet), it will not even try to go through the gateway (pfSense). Something weird is happening with either your web browser or web server.

    I see that you performed the telnet test from pfSense itself. I reckon when you have tested with a web browser it was from your workstation on the LAN? And you tested with another web browser? Cleared the cache and all that?



  • A real challenge :) Are you using a http proxy in your web browser?

    no proxy just plain tcp / http.

    If both your client and http server are on the same broadcast domain (same subnet), it will not even try to go through the gateway (pfSense). Something weird is happening with either your web browser or web server.

    client / wxp / 192.168.1.102/24
    http server / ubuntu / 192.168.1.10/24
    yes there are no 192.168.1.x:80 activity in the pfsense log.

    [2.1.4-RELEASE][admin@pfs.mydomain.org]/root(3): pftop | grep :80
    [2.1.4-RELEASE][admin@pfs.mydomain.org]/root(4): pftop | grep ":80"
    

    I see that you performed the telnet test from pfSense itself. I reckon when you have tested with a web browser it was from your workstation on the LAN? And you tested with another web browser? Cleared the cache and all that?

    Yes, using wxp. using 3 browsers namely; chrome, firefox and ie. Cleared / empty its /their cache.

    honestly it should had nothing to do with the pfsense box "but" replacing pfsense with a linksys home router - the http server page is viewable.

    i think this is going to be "FUN" !!!.



  • Damn, that's weird! I'm sorry, but I'm out of ideas. Hopefully someone else have an idea about what's going on.



  • i'll head up for a good rest as this will be a bumpy ride. Keep in touch. ;)

    to add,
    the only weird behavior that is happening from the LAN side is that; when browsing http://192.168.1.10 - browser goes to http://192.168.1.10:4444. (which obviously somehow has routed from internal to the external port).

    192.168.1.10:80 ==> 192.168.1.10:4444

    really weird.



  • I am starting to be impatient with this pfbox.

    I have resetup everything. I have removed LAMP and reinstalled them back.
    Now here's what happened in my setup…
    I was able to view the webserver within the LAN. but the frustrating part was I can't access the page through  WAN > NAT > LAN.

    I am nearing to dump this product. It does not worth wasting time.!



  • here's an update.

    pfSense work if the website is in static html pages but if you place a wordpress cms behind pfsense then NAT starts to fail. This is what i have encountered.  For some reason there should be a specific port that need to be enabled for wordpress be available to the public. Right after wordpress  setup connects to mysql - boom - page turns white.

    I did a curl -a www.mywebsite.com and it return nothing.

    Just to add to the mix. I also setup a drupal behind pfsense and it is rock solid. No glitches after set up (connecting back to the database)

    Anyone who has experience in fixing this?