USB NICs power off



  • Hi,

    I'm new to pfsense, but I finally have most everything running! One problem I haven't been able to overcome is this:

    Randomly, the USB 3 (not sure about on 2) ports simultaneously switch off, cutting off all network access. A reboot fixes this, or just unplugging and plugging back in the ethernet ports. Still, far from usable.

    I'm using a Foxconn NT-A3500 box, running of SD card, 4GB DDR3 RAM, plus 2x Gigabit USB3 adapters (WBTUO LE88179). To even get through the installation, I've had to use Alpha build 2.2 for freeBSD 10. I've tried looking for options in the BIOS and in pfsense to disable any USB timeouts/sleeps, to no avail. I've even tried setting 'sysctl hw.usb.power_timeout=0' through the console.

    Any ideas?

    Thanks!



  • You should try the adapter on the usb 2.0 ports to see if it exhibits the same behavior. 
    Do you know if that adapter has an asix chipset?  I never had luck with usb adapters and personally would not use them when needed for 100% uptime situations.

    I read on the freebsd forums that these settings might help.  Try at your own risk ;)

    Try to add this to your [FILE]/boot/loader.conf[/FILE]:

    hint.p4tcc.0.disabled=1
        hint.acpi_throttle.0.disabled=1



  • @BeerCan:

    You should try the adapter on the usb 2.0 ports to see if it exhibits the same behavior. 
    Do you know if that adapter has an asix chipset?  I never had luck with usb adapters and personally would not use them when needed for 100% uptime situations.

    I read on the freebsd forums that these settings might help.  Try at your own risk ;)

    Try to add this to your [FILE]/boot/loader.conf[/FILE]:

    hint.p4tcc.0.disabled=1
        hint.acpi_throttle.0.disabled=1

    Thanks! I'll give that a go. I'm hoping to stick to USB3, but I'll give it a go. Some tedious reconfiguring pppoe to go through another bus…

    Funny you should ask, it is an asix chipset, according to the console readout. Are there known issues there?



  • @Arenite:

    @BeerCan:

    You should try the adapter on the usb 2.0 ports to see if it exhibits the same behavior. 
    Do you know if that adapter has an asix chipset?  I never had luck with usb adapters and personally would not use them when needed for 100% uptime situations.

    I read on the freebsd forums that these settings might help.  Try at your own risk ;)

    Try to add this to your [FILE]/boot/loader.conf[/FILE]:

    hint.p4tcc.0.disabled=1
        hint.acpi_throttle.0.disabled=1

    Thanks! I'll give that a go. I'm hoping to stick to USB3, but I'll give it a go. Some tedious reconfiguring pppoe to go through another bus…

    Funny you should ask, it is an asix chipset, according to the console readout. Are there known issues there?

    About 2-3 years ago I was in a situation where I had to use usb adapters at a customer site.  I was having a ton of connectivity/throughput issues that I could not remedy.  The asix adapters seemed to be the culprit because when I switched to another vendor everything started working fine.  I think I went to realtek based adapters but I can't remember for sure.



  • If you have a VLAN capable managed switch you could just use the single onboard NIC with multiple VLAN interfaces, router-on-a-stick style.