Login successful, but browser not allowing it



  • Hello all, it seems this has only popped up in 2.1.4-RELEASE … but Chrome is every so often not letting me login to pfsense. The login is successful, and when I press enter, it just presents the login screen again. This is in the system logs when I login from Chrome:
    Jul 24 13:40:13 php: /index.php: Successful login for user 'Admin' from: 192.168.10.50

    But again, it doesn't let me login. I can go over to IE or Firefox and login successfully. But in order to get it to work in Chrome again, I will have to clear my cache. Weekly or every other day isn't optimal. Anyone have any solutions? I'm running Version 36.0.1985.125 m of Chrome.



  • What happens if you force a browser refresh with Ctrl-F5?



  • Tried that, and same results.



  • Very strange.  I use Chrome exclusively with the WebGUI and I've never had a problem.  When you say that it doesn't log you in, what do you mean exactly?  Does it just stay on the same login screen?  Is there any error or other indicator of weirdness?



  • It just shows the same screen and blanks out the fields, yeah. There's no errors at all, which is what I was hoping for. I suppose I could try to look at apache logs on the pfsense box itself?



  • Only happens with Chrome.  Any plugins of note?



  • Adblock, Adblock Plus, MightyText, and LastPass. I tried disabling all of them and restarting Chrome, but no luck. Clearing cache is the only thing that resolves it, but only temporarily.

    Note: If I open a 'incognito' window, it works.



  • Something to do with cookies maybe?



  • Just a guess, but are you using https for pfSense?  If so, might be worth atry to switch back to http for testing.

    Perhaps an SSL complaint inside chrome or one of the addons?



  • Yes, it might have to do with cookies, not sure why now as opposed to the previous 8 months I've had this up and running… and yes, I'm using https for administration.



  • Your Content Settings are all at default or recommended?



  • Content settings in Chrome are default, I've never mucked with them. I've now uninstalled every extension in Chrome except my password manager, which I'm not disabling to fix this issue. I've had to delete cache and cookies more times than I am comfortable with ONLY to resolve this issue. If this doesn't solve it, I'll just use FF or an Incognito window, not sure how to troubleshoot this any further.



  • So I've now run into the same issue with another pfsense installation in Chrome as well. And it wouldn't be so bad if it was just on one computer. Is there some sort of logs I can look at on the backend to try to debug this problem? I'm about ready to pull my hair out. Looks like the lighttpd.log is binary, so I can't read that…

    I've run into it once or twice in Firefox, but restarting the browser fixed it there. Am now running Version 38.0.2125.24 beta-m (64-bit) but it also happens on my Mac, and on my work laptop as well. Chrome is pretty much straight out now. And switching certificates from my wildcard to the self signed that the install comes with makes no difference. I can give someone a username if they'd like to help figure this out... but I'll take anything I can get at this point.

    Anyone? Please?

    Edit:
    Upon doing some inspection with Fiddler, it looks like my Chrome install is doing something odd with cookies... I see this in my Chrome session:

    Request sent 150 bytes of Cookie data:

    drmt_cs=w3trhWYyob3yFWvgSpzQ1GNw%2C%2C; PHPSESSID=14c8aa25b8269d0e4da32d5f56676a65; cookie_test=1409391525; PHPSESSID=1361ae9d80d41e78ed2b509ed397e727

    Whereas with Firefox (Or a incognito Chrome session), I see:

    Request sent 66 bytes of Cookie data:

    cookie_test=1409391955; PHPSESSID=df69291fcaa88d76a0bed7862c3bed72

    2nd Edit: I've now cleared cache once again, and uninstalled/reinstalled Chrome. Would appreciate any tips if someone has one while I wait for this problem to occur again.