PPPoE issues – how to make logging more verbose?



  • I'm attempting to use a Draytek DV130 modem to do a VDSL bridged internet connection, with the PPPoE done by pfSense. So far I've tried release 2.1.2, 2.1.3, 2.1.4 (all vmWare VMs) and pfSense 2.1.4 on a HP Proliant MicroServer Gen8. No matter what I do, PPPoE won't connect. I've ensured the "Configure null service name" tickbox is checked as this is not required by my ISP.

    I have ruled out my ISP/Modem being the issue because if I plug my modem straight into my Windows 7 desktop computer, I can dial out using PPPoE and get the proper WAN IP and get my internet connection working.

    The PPP log is full of these:

    Jul 27 17:32:17 	ppp: [wan_link0] Link: reconnection attempt 4 in 1 seconds
    Jul 27 17:32:18 	ppp: [wan_link0] Link: reconnection attempt 4
    Jul 27 17:32:18 	ppp: [wan_link0] PPPoE: Connecting to ''
    Jul 27 17:32:27 	ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Jul 27 17:32:27 	ppp: [wan_link0] Link: DOWN event
    Jul 27 17:32:27 	ppp: [wan_link0] LCP: Down event
    

    I have deployed this (Draytek DV130 + pfSense) at least half a dozen times sucessfully, and it's always very easy to do! But this time around, I can't for the life of me get it going. I've tried everything I can think of. I've compared the settings against other setups that I know work fine (same ISP w/ VDSL service, but other premises) but it still doesn't work.

    Is there some more verbose logging I can get out of this?

    I presume the next step to figuring out what's happening here is to turn on more verbose logging at the pfSense end. How can I accomplish this?



  • I got it working – the issue was the firmware I was running on my modem (3.7.5.2) has a bug with PPPoE. Using firmware version 3.7.5 I was able to get it to work.