X1000 firebox finally working with PFsense!



  • After countless nights of pain trying to get this to work, I thought I would share my experience to see if anyone else had similar nuances.

    I mainly followed the guide here: http://documentation.dbernhardt.com/pfsense/article.html so will try not to repeat anything.

    1. I couldnt get any console output to putty using a "null modem" cable. Eventually, I hacked my own straight through serial cable using the full handshake protocol which proved successful. Guide here: http://www.lammertbies.nl/comm/info/RS-232_null_modem.html#full

    2. Flashing the freedosbios image seemed to make little difference and I wondered if I actually flashed it at all. Here's why.

    • connect at 9600, run awdflash after 3 beeps, seems ok
    • connect at 19200, 3 beeps and gibberish through putty
    • connect at 115200, 3 beeps and nothing (attempted to get into BIOS screen)
    • tried awdflash with various files, X750EB2, 3, 6, 7. No affect on above.
    • tried changing flow control settings in putty and device manager, again no effect.
    • booted fb without card and LCD shows boot error, with options to change baud rate. I tried these too, though seeing this made me think i didnt actually flash the FB at all.

    Note that now I read on the PFsense page on flashing FB's you dont need to do that for this model :S

    1. tried booting the nano bSD image on a new CF card, at various baud's, though I knew 9600 was the expected one to work on.

    Eventually the problem came down to the CF card needing to be formatted to FAT, not something that seems to be mentioned. With the CF installed with the image on a FAT formatted card, all setup screens came on over 9600 baud. After which time you can enter the GUI via web browser.

    LCDproc-dev also seems to work without any issues following restart. Tonight will play around with it more, get the arm and disarm lights working.

    Its also good to mention I got a 512 DIMM to get this box up to PFsense's needs, this seemed to go in without issue and didnt change the issues I experienced above.

    Thanks,
    Adam.


  • Netgate Administrator

    Thanks for the write up and sorry you had such a hard time. A couple of points:
    The guide you followed doesn't make clear that it is for the X-e boxes only and the X1000 is not one of them! There is no bios either needed or available for the X-Core boxes. Fortunately the awdflash program has some safety features because had you forced it to flash, which you can do, it would have bricked your firebox. As you found the page in docs should cover everythign you need to do:
    https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#X-Core

    It should not matter what the format of the CF card is. The image writer simply copies the Nano image bit for bit including the new format which is UFS. Odd that you had a problem there.  :-\

    Thanks for the null-modem link. As you found FreeDOS is pretty basic and requires full-handshake capability. The pfSense console code does not though, you should be able to see that with just a three wire connection.

    The X-Core box is picky about what DIMMs it recognises, could you give the details of your working module?

    Steve



  • Thanks Steve,

    I would agree the image should be bit for bit and the file format shouldn't make a difference. Its weird, I had this issue whether I used dd or Win Disk Imager. I'm using a transcend 4GB Industrial Grade CF card.

    I guess that I never actually did anything to the bios at all then, from what you say.

    For RAM choice it was pretty simple: I took the advice of the pfSense docs: https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox and used the KVR100X64C2/512 module - all in all £10 from fleabay.

    Its been a learning curve but good fun! I'm now going to convert an XTM 505 as my main box.

    Thanks,
    Adam.