Como atualizar pacotes (SAMBA, lighttp, squid) sem comprometer funcionamento?



  • Pessoal…

    Preciso atualizar alguns pacotes por exigência de uma certificação, mas não posso comprometer o que esta funcionando dos servidores PFSENSE.

    A consultoria passou um SCAN apontando vulnerabilidade...recomendaram a atualização de alguns pacotes para as seguintes versões.

    SAMBA3.6.23, 4.0.16, 4.1.6, ou superior

    LIGHTTP 1.4.34 ou superior

    SQUID 3.0, 3.1 ou superior

    OPENSSL 1.0.1g

    OPENSSH para a mais recente.

    Acontece que os firewalls são os de produção e tenho o squid/squidguard autenticando no AD por NTLM e tudo quanto é função possível....funcionando perfeitamente

    como posso atualizar estes pacotes sem perder funcionalidades, parar serviços, etc....

    Pelo que andei vendo alguns tem que atualizar via linha de comando....

    Alguém pode me dar algumas dicas como fazer isso?