No connection on DMZ



  • Hey everyone,

    I recently ordered a TP-LINK TG-3468 NIC to use as an OPT interface that I want to set up as a DMZ. I tried setting up the DMZ today but I can't get any connections when connected to it.

    Here are my configurations:


    The Block private networks and Block bogon networks options are unchecked. Is there anything I'm doing wrong? Can somebody help me out in terms of what I need to change in order to get this working?

    Much appreciated!



  • Get rid of your DMZ rules and then add just this one:

    IP4* | DMZ Net | * | * | * | * | None

    Does it work now?  If so, then start creating your custom rules and check connectivity after each one.


  • Banned

    Have you configured outbound NAT??

    I have issues with outbound NAT to VIP…cant get it to route no matter what I do.



  • @KOM:

    Get rid of your DMZ rules and then add just this one:

    IP4* | DMZ Net | * | * | * | * | None

    Does it work now?  If so, then start creating your custom rules and check connectivity after each one.

    I'll give this a shot and report back whether it works or not!

    @Supermule:

    Have you configured outbound NAT??

    I have issues with outbound NAT to VIP…cant get it to route no matter what I do.

    No I haven't, is this necessary?


  • Banned

    You need to tell the interface where to get out :D

    Use WAN as interface and set the rest as any.

    I bet it works…



  • @Supermule:

    You need to tell the interface where to get out :D

    Use WAN as interface and set the rest as any.

    I bet it works…

    Could you describe how I do that?  ;D  or is it like described here (http://doc.m0n0.ch/handbook/examples.html#id11643686) in the 1:1 NAT section?


  • Banned

    http://ww2.jreyes.us/wp-content/uploads/2014/01/4.jpg

    Use your /24 subnet as source and set the interface to WAN and the address translation to WAN interface



  • @Supermule:

    http://ww2.jreyes.us/wp-content/uploads/2014/01/4.jpg

    Use your /24 subnet as source and set the interface to WAN and the address translation to WAN interface

    Ah ok, but then I have to disable automatic outbound NAT rule generation, does that mean I'm going to have to do a lot of manual configuration for other devices?


  • Banned

    It shouldnt be that big of a pain, but try and see if it works and report back…



  • @MarkVLK:

    @KOM:

    Get rid of your DMZ rules and then add just this one:

    IP4* | DMZ Net | * | * | * | * | None

    Does it work now?  If so, then start creating your custom rules and check connectivity after each one.

    I'll give this a shot and report back whether it works or not!

    I tried disabling all the other rules and adding this one only.

    I noticed that the interface appears to be down, but I think it was down before I changed the rules too. It is enabled in the interfaces tab, what would be causing it to be down?



  • @Supermule:

    It shouldnt be that big of a pain, but try and see if it works and report back…

    I tried that but still no luck, but as I posted right before this, looks like my DMZ interface is down. Any ideas why that might be?


  • Banned

    It doesnt work if the interface is down….and it means its not connected anywhere.



  • @Supermule:

    It doesnt work if the interface is down….and it means its not connected anywhere.

    I finally got my Wii U to connect to the internet through the DMZ interface. I forgot to set the static IP on the Wii U :-X  once I did that, it worked.

    I didn't realize it showed as "down" if nothing was actively connected to it, it goes up once the Wii U turns on. It actually worked without the manual NAT rules, but I'm getting the same error when trying to play online as I was when connected to LAN which was the only reason I set up this whole DMZ in the first place… Very frustrating.

    NOTE while I was writing this, online matchmaking actually worked, but then I got a communication error mid-game so not sure if that was still something broken on my end or something on the other guy's end (there was only 1 other player).

    Anyway, I'll keep at it, at least I know the DMZ has the ability to connect to the internet. Thanks for all your help everyone!



  • Hi everyone,

    I wanted to try to revive this thread since I'm still having issues. My DMZ interface seems to work as far as browsing the internet, but whenever I try to connect to Mario Kart 8 online via my Wii U, I get Error 118-0516 (http://www.nintendo.com/consumer/wfc/en_na/ds/results.jsp?error_code=118-0516&system=Wiiu&locale=lang). More info from others with similar issues here (http://www.gamefaqs.com/boards/700050-mario-kart-8/69336625).

    I've tried every solution recommended by others in this thread and some others I've found around the web, but nothing works for me  :(

    Here are all the settings I have for my DMZ interface at the moment. If I didn't include a setting in the screenshot, you can assume it's empty or not checked.

    Just a note on that last image, I'm aware that the mapping I have entered isn't currently in effect because it's set to automatic outbound NAT rule generation, but that's because when I had it on manual with this same mapping entered I was still having the same issues so I reverted back to automatic.

    I don't know if I've been improperly setting up 1:1 NAT or Outbound NAT or not setting proper firewall rules for the DMZ interface or what but I've tried everything I can think of and still no luck. I will be forever in debt to anyone that helps me resolve my issues!



  • Mark,
    You are not displaying the good RULE interface. What you need for playing, is INCOMMING connection. What shows your DMZ tab in your FW rules are your OUTGOING trafic (pass or block).
    On your WAN tab, specify an allow all rule to DMZ subnet destination. So that your DMZ play its role : being demilitarized…

    I'm afraid you will have to deal with AON to... (manual NAT). Unless you struggle with port forwarding from each of your game support (Nintendo / Sony / steam...), and configure the good ports to be forwarded for each service.
    Believe me, you'de better work on Manual NAT (and static ports) rather thant seeking for editor's information about port forwarding.