UPnP not working correctly with XBox One [solved?]



  • Subject says it all.  The XBone apparently isn't talking correctly to our miniupnpd, because it comes back from testing with "strict NAT," meaning it isn't able to open the ports it wants.

    Oddly, I do see a single mapping in the UPnP table for the XBone, but it apparently isn't enough.

    Is there a way to make miniupnpd log more debug info (I have a remote syslog server setup for "Everything" in pfSense)?  I'd be more than happy to work with a developer to get this fixed, and I'm not against putting up some money for it if it comes to that (I was part of the original push to get UPnP on pfSense in the first place).

    My XBox 360s work fine (I have 2 that get used regularly), map a port to themselves and report no errors/warnings about NAT – it's specific to the XBone.



  • Hate to talk to myself, but I just realized this could be potentially moved to the gaming forum.

    It also sounds like they have the solution over there.  Apparently the default pfSense behavior of "dynamic port" outbound NAT causes the problem.  UPnP still needs to be enabled, but it isn't the magic bullet that it was with the 360; the static port NAT option has to be turned on for the XBone.

    https://doc.pfsense.org/index.php/Static_Port

    Why the XBox One has problems with this and the XB360 does not, I have no idea (or maybe the 360 does, but the NAT tests it performs are just less thorough).

    I'm probably going to enable it for all of my Xboxen just to be thorough.  :)