PFsense not showing opt secured



  • I have an internal wifi card (ath0) that is on the opt interface. Accessing internet through the card and pfsense is no problem. But despite enabling WPA2/AES the wifi shows up as not secured. Even my old Brother printer complained about it being an unsecured network and my iphone connects but there is no lock next to the icon. The card mode is "Access point", enable WPA is checked, WPA2, wpa pairwise is set to AES, and Enable IEEE802.1X Authentication is checked but still no lockdown. A very secure password is also set.

    Running PFSense 2.1.4-RELEASE (amd64). Any ideas? Also, an FYI, the web site "pfsensesetup.com" was blocked by PFSense. Thinking this was in error I excluded it from the rule set. Then Avast killed it so I figure it must be a bad website.


  • Rebel Alliance Global Moderator

    What?  How would pfsense block that site - there is no content blocking/filtering in pfsense out of the box.. Did you install some package, squid, snort?

    "Thinking this was in error I excluded it from the rule set."

    What ruleset??

    http://pfsensesetup.com/ while I show it a really old version of wordpress, scanning that site shows not issues to the user.

    So your saying that setting security features on wifi network is not working.. And no matter what settings you put its just an open network?

    I am confused when you say things connect - clearly you would know if the network is secured or not if you connected to it.  You sure your using an unique SSID..  And there is not something else broadcasting the same ssid your using that is open?



  • Snort,arp watch and PFblocker are installed. Snort did the blocking initially then the free version of Avast also blocked it on the client PC.  And yes I am absolutely sure it is not secured. I have one device set with the passphrase which does not connect to the opt interface wirelessly and 2 wifi devices with no password that connect and access internet no problem. I dont remember if the exclusion was on PFBlocker or Snort, I have several countries blocked, or Snort, but either way my real issue is why the wifi is not showing up as secured. I have reset states and the issue has been present since BEFORE I installed Snort, Arpwatch or PFBlocker.


  • Rebel Alliance Global Moderator

    Not a big fan of using pfsense as AP..  Just makes no sense to me – I would use a real AP, just so many more features and functionality that way.

    But I do believe a ifconfig should show your hostap settings.  When you do ifconfig do you see a hostap section?  What does it show?