Error 422 - Snort VRT Updates - SOLVED



  • Has anyone else ever successfully resolved this error message after trying to download Snort VRT rules updates:

    "Snort VRT rules will not be updated. Server returned error code 422."

    –-------------------------------------------------------

    See two Snort updates screen shots in *.jpg format attached to this message. Those screenshots indicate:

    A. Rules download correctly:

    Snort GPLv2 Community Rules
    Emerging Threats Open Rules

    B. Rules download  incorrectly:

    Snort VRT Rules

    Other information about this case:

    1. Choosing to "Force" the update by clearing the MD5 hashes does not produce a different result.

    2. I am not a paid customer; I am a subscriber of the free version.

    3. I've tried a variety of typical troubleshooting: reboot, re-apply oink code, modify and apply the rules configuration, uninstall/reinstall Snort... but with no change in the error behavior.

    4. My pfSense installation is simple: pfSense 2.1.4 running on an adequate Intel processor rig (hardware tests error free); pfSense config is not virtualized; Snort version 2.9.6.0 pkg v3.0.13 with Barnyard2; no other known errors in pfSense.

    I'm perplexed. Any thoughts would be appreciated. Thank you.

    ![Snort Updates Download Error.jpg](/public/imported_attachments/1/Snort Updates Download Error.jpg)
    ![Snort Updates Download Error.jpg_thumb](/public/imported_attachments/1/Snort Updates Download Error.jpg_thumb)
    ![Snort Updates.jpg](/public/imported_attachments/1/Snort Updates.jpg)
    ![Snort Updates.jpg_thumb](/public/imported_attachments/1/Snort Updates.jpg_thumb)



  • This issue can be corrected by upgrading to Snort 2.9.6.2 pkg v3.1.1.

    ;D