Problems with routing on one interface.



  • Hi guys

    I I'm running pfsense 2.1.4. Got everything working except the routing from other ip scopes on the same LAN interface

    My set up is

    pfsense wan x.x.x.x
                                                                              |
                                                                              |
                                                                pfsense lan 10.81.2.0/24
                                                                pfsense gw  10.81.2.1/24
                                                                              |
                                                                              |
                                                                router with a untagged vlan2 and ip 10.81.2.5
                                                                router have many vlan comming in and routed to the FW

    The only network that is working is the 10.81.2.0.
    On the router I have 80 vlans coming in and work just fine. The problem is when I try to ping form a vlan to the pfsensebox it just drops. 
    I can see that the icmp is received at the LAN int on the FW but not routed back.

    The FW rules are ok and the I have a route back to my 80 vlans.

    See pictures







  • Banned

    You do notice that your GW and LAN are not on the same network??

    You are basically doing it wrong…. Let pfsense handle the VLANS and skip your router. It will make it a lot simpler...



  • Yes I know that the GW and the lan INT is on the same network, is it a problem ?.

    About the vlans, I don't want to have 80 vlans in the gui of the pfsense box. I will be very hard to see all the vlans.


  • Banned

    Have you enabled ICMP rule so the traffic is allowed ;)



  • Hi

    Yes everything is allowed even icmp as you can see on the attached pictures.

    I really don't know what to try ?

    Hilsen Johan


  • Banned

    Post picture of WAN interface and routing tab in firewall

    I want to see the gateway on WAN.

    And you dont have any GW defined on the LAN interface?



  • Ok here comes some pictures  :)





  • Banned

    LAN interface -> select NONE in gateway and report back.

    Send me a PB and I can remote in via teamviewer and help you .



  • Lan INT is set to NONE  :-[

    I would really appreciate a teamviewer session when do you have time ?

    Regards Johan


  • Banned

    Sent PB.

    @viggen:

    Lan INT is set to NONE  :-[

    I would really appreciate a teamviewer session when do you have time ?

    Regards Johan
    [/quote]