RDP blocked by pfSense?



  • Hi, I'm trying to setup RDP on my local network, but the RDP program gives error: unable to connect.
    SSH works, so I checked pfSense and added a port forward for 3380 from computer 1 to computer 2.
    Same error?


  • Rebel Alliance Global Moderator

    Well for starters 3380 is not the default port, 3389 is – are you trying to do this from outside from your wan to your lan?  Are you trying this from a lan machine to another lan machine?  If so then pfsense has nothing to do with that connection unless your routing segments on your local network with pfsense?

    Lets get some details - what is the ip of source, ip of dest machine - make sure your using the correct port for rdp - 3389 is default, did you change it on dest machine to 3380?  Are you running firewall on dest machine, if so even if coming from other than local network you would have to adjust the built in windows firewall to all for that.

    Also if you are attempting from outside your network, and doing a forward - you sure your actually outside - attempting from local lan machine to public IP to get forwarded back in is loopback or reflection - did you enable that in pfsense?

    This sounds like your just local "from computer 1 to computer 2." if your going from say 192.168.1.x to 192.168.1.y then pfsense would have nothing to do with that connection..