Sarg Reports Constantly Need Forced Schedules (Squid)



  • Hi,

    I'll start by saying I am a pfSense noob, have little Linux experience beyond playing around with Ubuntu every so often, and this is my first journey into software routers.

    I seem to be having a lot of difficulty with getting Sarg to play nice with Squid.  More often than not when I click to view a report, it tells me it can't find the index file and then I have to enter the schedule I have set up and force it.  Just today, every time it is forced I get a new report with the same name as last time.  Note the top three:

    Squid is set to transparent proxy mode, cache is disabled as well as I could manage, and reports are set to default settings with no log rotation.  Probably best if I post screenshots of how Sarg is set up to report:

    Any help would be appreciated!

    Thanks



  • Nobody else has any issues with Sarg reports and Squid?


  • Moderator

    Have you seen the following thread:

    https://forum.pfsense.org/index.php?topic=79804.0



  • I've just read that now, thank you.

    Unfortunately I have the reports selected as suggested in that thread.

    I have found that I now have multiple reports for each day, and none of the earlier ones work, even after forcing the schedule.



  • Does anyone have any ideas?