Sem acesso Wegui com Proxy não transparente.



  • Pessoal, estou com um problemasso.
    Minha situação é o seguinte, tenho um proxy configurado na porta 3128 e todas as demais portas bloqueadas. O meu webgui é acessado pela porta 8080 (troquei o padrão).
    Ontem quando fui finalizar, mudei para SSL então perdi o acesso ao meu pfsense (https://192.168.0.1:8080).
    Pelo Firefox nem carrega a pagina, e pelo Internet Explorer eu acesso, porém os menus de cima não aparecem  :-\

    Já tentei adicionar regras no firewall pelo comando easyrule mas não tive sucesso.
    Existe alguma maneira de desativar o SSL pelo shell? (ainda tenho acesso pelo putty)



  • uma maneira simples (porem nao recomendado) é alterar o config.xml.. ja fiz isso algummas vezes para outras situacoes .. nao sei se vai funcionar nesse caso. mais nao custa tentar.. tente tambem configurar o navegador para nao usar proxy talvez consiga acessar assim..



  • Pode te ajudar a encontrar o caminho do xml da configuração:

    http://tecnologoderedes.blogspot.com.br/2012/05/do-not-panic-administrator-pfsense.html



  • E para a mudança ter efeito imediato (sem precisar reiniciar o servidor), basta apagar o arquivo /tmp/config.cache e aplicar a opção 11 na console para reler o arquivo de configuração.

    Por coincidência tive que fazer isso agora! hehehe. Alterei o acesso pra http, mas a regra de acesso externo à porta WAN para acesso somente https, aí perdi o acesso.



  • Caras, vocês são demais! Valeu pela ajuda, hj à noite vou testar e depois posto o resultado aqui  :D



  • Consegui acesso novamente ao Webgui, porém quando ativo o SSL nela, perco acesso novamente :/



  • Só pra constar, abri o arquivo conf.xml (está em / <root>depois /cf/conf),  através do WinSCP e dei um buscar, coloquei o numero da porta e ele já achou a linha de configuração. Então editei para

    <webgui><protocol>http</protocol>
    <noautocomplete><port>8080</port>
    <max_procs>2</max_procs></noautocomplete></webgui>
    (obs: quando ativa HTTPS fica uma linha com a chave da criptografia que pode ser apagada)</root>



  • @henriquejensen:

    Consegui acesso novamente ao Webgui, porém quando ativo o SSL nela, perco acesso novamente :/

    Atualizou a regra pra aceitar o acesso externo (wan) na porta 443?
    Se não vai perder o acesso novamente.



  • Feedback.

    No fim das contas tive que deixar o acesso ao webgui na porta 80 mesmo pq estou usando Wpad, ainda nao consegui fazer com que o wpad funcione com o webgui em outra porta, mas enfim, o problema q relatei no começo do tópico era o próprio squidguard bloqueando, a solução foi incluir o ip do pfsense numa common ACL com regra Whitelist.



  • O squidguard bloqueando o acesso pela WAN?

    Deixa somente a interface LAN e loopback pra usar o squid. Se a wan tiver no squid podem usar o teu proxy.



  • @epboeira:

    O squidguard bloqueando o acesso pela WAN?

    Deixa somente a interface LAN e loopback pra usar o squid. Se a wan tiver no squid podem usar o teu proxy.

    Não entendi muito bem oque vc quis dizer epboeira, mas nas opções de Proxy Interface do Squid só tem a LAN selecionada.
    Qual seria a função do loopback?



  • se essa opção estiver DESMARCADA esse tipo de problema não acontece

    System: Advanced: Admin Access

    Disable webConfigurator anti-lockout rule
    When this is unchecked, access to the webConfigurator on the LAN interface is always permitted, regardless of the user-defined firewall rule set. Check this box to disable this automatically added rule, so access to the webConfigurator is controlled by the user-defined firewall rules (ensure you have a firewall rule in place that allows you in, or you will lock yourself out!) Hint: the "Set interface(s) IP address" option in the console menu resets this setting as well.

    Desabilitar regra anti-lockout do webConfigurator
    Quando isso estiver desmarcado, acesso ao webConfigurator na interface LAN é sempre permitido, independentemente do conjunto de regras de firewall definido pelo usuário. Maque essa opção para desabilitar essa regra automaticamente adicionada, para que o acesso ao webConfigurator seja controlado pelas regras de firewall definidas pelo usuário (tenha certeza de que possui uma regra de firewall que lhe dá permissão de acesso, ou você não conseguirá mais o acesso!) Dica: a opção "Configure o endereço IP de interface(s)" no menu do console reinicia essa configuração da mesma forma.



  • @henriquejensen:

    Não entendi muito bem oque vc quis dizer epboeira, mas nas opções de Proxy Interface do Squid só tem a LAN selecionada.
    Qual seria a função do loopback?

    Olha, já vi posts recomendando acrescentar a interface loopback e outros dizendo pra tirar. Não saberia te informar qual a vantagem/desvantagem, mas penso que tem a ver com dns, já que uso o pfSense como dns server e o squid faz as requisições por ele mesmo.

    Mas deixo pros mais experientes nos dar uma melhor resposta, pois também gostaria de saber qual a recomendação.  :P



  • @epboeira:

    @henriquejensen:

    Não entendi muito bem oque vc quis dizer epboeira, mas nas opções de Proxy Interface do Squid só tem a LAN selecionada.
    Qual seria a função do loopback?

    Olha, já vi posts recomendando acrescentar a interface loopback e outros dizendo pra tirar. Não saberia te informar qual a vantagem/desvantagem, mas penso que tem a ver com dns, já que uso o pfSense como dns server e o squid faz as requisições por ele mesmo.

    Mas deixo pros mais experientes nos dar uma melhor resposta, pois também gostaria de saber qual a recomendação.  :P

    Interessante, no meu caso pra proxy não transparente eu só libero a porta 53 pra lan mesmo e funfa de boa. Mas é legal a gente estudar mais à fundo todas as funções básicas do pfsense pra quando der alguma zica saber por onde começar né….aheuhauea


Log in to reply