Putty or Kitty settings for Lanner FW-7535 serial console?



  • Hi,

    I'm trying to access this device via serial console and can't make it work correctly.  Mainly I want to be able to select a boot device via serial console, but I can't get the function keys to work.  I've tried a ton of different keyboard settings and nothing seems to work.  I can't get it to show output beyond the pfSense boot menu either.  I tried all of the possible redirection settings in the BIOS.

    Has anyone ever gotten the serial console working well enough to do an install or should I just give up stick with the VGA console?  The main reason I wanted to use the serial console was so I could take screenshots of the install.  I can always fire up a VM if needed.


  • Netgate Administrator

    Two possibilities occur to me.
    Your console cable may not be wired for hardware flow control. Do you see output from the bios over serial?
    Generally you can only send a limited set of keys over serial so function keys don't work and neither does the del key. There are often equivalent key combinations to use over serial such pressing tab instead of del to enter the bios setup.

    Steve



  • My initial post was a bit lacking  :-\

    I can get it mostly working.  For example, I can use TAB to get into the BIOS, change settings, save, exit, etc..  Once pfSense is installed everything works as expected.  Really the only thing I can't do is press (ex:) F5 to boot from a non default device.  My primary use case would be doing a re-install.  The hard disk with pfSense installed is the default boot device and I can't choose to boot from a USB device without plugging in a keyboard and using it to press (ex:) F5.


  • Netgate Administrator

    So the 'F5' selection is a BIOS option to choose something other than the boot priority list from the BIOS setup?
    What type of BIOS is it? As I say there are often alternative key combination to use via serial redirect. For example for a relatively new Award BIOS:

    Press TAB to enter Setup screen.

    Press Esc twice to take effect.

    Function keys won't work, use direction keys and choose menu items instead of hot key. Do not un-plug cable while Console Redirection is working and bios is booting up.

    Steve



  • I don't have the device in front of me, but I think the F5 option looked more like a bootloader that came after POST.  It's looked the same on every pfSense install I can think of.  Since the BIOS uses TAB and, as far as I noticed, avoids the use of function keys, I'd be surprised if they were using function keys for boot device selection.

    Actually, I have a screenshot…



  • Netgate Administrator

    Ah right, that's the FreeBSD bootloader. You should be able to select those options using the serial console though it escapes me quite how.  ::) Maybe by pressing 1,5 or 6? Or using the cursor keys?

    Edit: Pretty sure it's using the number keys on nano at least.

    Steve



  • ryan29,

    For putty, under Terminal->Keyboard, have you tried using 'VT100+' for the function keys?

    Putty default to sending ~ when function keys are pressed. With 'VT100+' the function keys F1, F2 can be used to select nanobsd boot slice.



  • I got to test this device again and using the number keys works.


Log in to reply