Virtual IP não direciona para IP Privado



  • Preciso criar um ip virtual e que ele seja direcionado para uma máquina na minha LAN.
    Para isso crio uma interface virtual em Firewal -> Virtual IPs e depois crio uma regra NAT 1:1 especificando o ip externo e o ip interno relacionado, também crio uma regra para liberar no firewall.
    O problema é que além de não direcionar para a máquina especificada, o endereço do IP Virtual leva para a interface webadmin do pfsense.



  • as configurações estão corretas, o erro foi acessar pela rede local e por isso caia na interface webgui https
    a solução é acessar pela rede externa que funciona



  • Por curiosidade, vai usar NAT 1:1 porque motivo?



  • tenho algumas maquinas acessadas por ip publicos, com servicos de email, servidor web e banco de dados
    quero colocar todas atrás do roteador/firewall com pfsense porque algumas delas já foram invadidas por estarem vulneráveis



  • Certo, tenho o mesmo cenário mas não uso o NAT 1:1, faço o NAT : Port Forward.
    Pois pelo que sei o NAT 1:1 seria para que sua máquina responda diretamente no IP externo.

    Para estes serviços que você falou pode ser feito o Port Forward que funciona tranquilo.

    Se eu estiver enganado, por favor, façam seus comentários.
    Obrigado.



  • Foi uma solução genérica da minha parte usar o NAT 1:1
    Testei com Port Foward e funcionou, essa última solução é mais específica e segura



  • Ok.



  • Olá,

    Tenho o mesmo cenário na minha empresa:

    Um ip público(200.200.200.200) que é usado por um servidor web apache. Criei uma regra no NAT para acesso externo, porém quando tento acessar da minha rede local utilizando o ip público, aparece o erro 404 - Not Found.

    Com o ip interno da LAN(192.168.1.x) acessa normalmente, mas preciso acessar pelo ip publico, uma vez que os colaboradores acessam o site em links de terceiros( que utilizam como link o ip público).

    Como conseguiu?



  • Olá,

    Consegui resolver habilitando o NAT Reflection mode for port forwards.

    Para acessar: System->Advanced->Firewall/NAT->Network Address Translation->Enable(NAT+Proxy).

    Achei nesse link: https://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks

    Nele tem uma opção por DNS também.