WAN external Public IP not renewed Cable DHCP



  • Hi all!

    I have PfSense 2.14 setup fine behind a Cisco 3212 Cable Modem.  It's a real Modem. ;-)

    When the Modem is rebooted, PfSense doesn't get the new WAN IP-Adress from the Provider (Unitymedia Germany) via DHCP.

    If I reboot PfSense afterwards the WAN IP is renewed and everything is working again.

    Same thing happens from time to time. (When the Provider resets the connection? I don't know.)

    The IP is regulary renewed when the Leasetime expires. (Entries like "New IP detected" and then same IP given)

    To me it looks like PfSense is not asking for a new IP through the Modem as long as the Lease is still valid.

    Is there any way to make PfSense establish a new connection without rebooting?

    Suggestions?

    El Buco

    Just saw, it's nearly the same question as here: https://forum.pfsense.org/index.php?topic=80477.0

    Seems to be a feature, not a bug. ;-)


  • LAYER 8 Netgate

    I have a blank VLAN with my cable modem and pfSense WAN port on it.  I would periodically experience similar issues.  I blamed the cable company until I put a mirror port and wireshark on the WAN.  DHCPDISCOVER would go out, DHCPOFFER would come back, and then nothing.

    I switched my WAN interface from Realtek to Intel and haven't seen it since.

    You should be able to coerce pfSense into reacquiring a lease by waiting until the cable modem has gone through its startup and sync gyrations then either releasing in status->interfaces or simply unplugging and reinserting the cable from the WAN port to the modem.  A down/up makes it reacquire.  Cable providers do all kinds of strange stuff with their DHCP.



  • Thank you, Derelict!

    "DHCPDISCOVER would go out, DHCPOFFER would come back, and then nothing."

    Sounds to me like a PfSense issue.

    My PfSense runs on an Intel-MB, I won't be able to switch to Realtek for trial. ;-)

    Unplugging may be easier, but it's not a solution as there is not everytime someone onsite and VPN must work and I can't fix it remote without Internet connection.  :(

    Maybe it will be fixed it some future release… I'll try to get a static IP from the Provider.

    "Cable providers do all kinds of strange stuff with their DHCP." Sure. There is a "DHCP-Attack" ;) on the WAN Interface as well. One 10.x Client requesting 3 times a second, no offer. (Or no respond. Who knows?)

    Buc


  • LAYER 8 Netgate

    No so much pfSense as FreeBSD.  It was like the realtek interface just went "deaf."

    Not that this is anything like what you're seeing.  You won't know without a pcap (from outside pfSense's WAN interface.).



  • @itsol:

    Hi all!

    I have PfSense 2.14 setup fine behind a Cisco 3212 Cable Modem.  It's a real Modem. ;-)

    When the Modem is rebooted, PfSense doesn't get the new WAN IP-Adress from the Provider (Unitymedia Germany) via DHCP.

    If I reboot PfSense afterwards the WAN IP is renewed and everything is working again.

    Same thing happens from time to time. (When the Provider resets the connection? I don't know.)

    The IP is regulary renewed when the Leasetime expires. (Entries like "New IP detected" and then same IP given)

    To me it looks like PfSense is not asking for a new IP through the Modem as long as the Lease is still valid.

    Is there any way to make PfSense establish a new connection without rebooting?

    Suggestions?

    El Buco

    Just saw, it's nearly the same question as here: https://forum.pfsense.org/index.php?topic=80477.0

    Seems to be a feature, not a bug. ;-)

    Olá Itsol.

    Was searching for some solution to this poblema. Almost no one suffers from this evil DHCP WAN.

    It was when I came across your doubts and the solution that was given. I had to disagree with the "Derelict" also. Ai continued my search and found this post: https://forum.pfsense.org/index.php?topic=57258.0

    I have not read everything, went straight to the last page and read something talking ta communication rate of the network interface where the individual arrow interface to communicate to 100BaseT. Well, it cost not try, I changed my settings to "Full-Dublex 100BaseT." I did my tests and it worked oa _ || _: D

    my system: "2.1.5-RELEASE (i386) built on Mon Aug 25 07:44:26 EDT 2014 " Interface: Realtek 10/100.

    Well, there is a hint.
    Good look.


Log in to reply