pfSense 2.1.4 - Autenticação Ad Win 2008 Server



  • Bom dia Pessoal,

    Preciso de ajuda para autenticar meu pfSense 2.1.4 no Windows Server 2008, como posso saber se o mesmo esta autenticando? Existe algum log que posso verificar se houve algum erro de configuração ?

    Segui vários artigos porem não obtive sucesso nessa configuração.

    Alguém  utiliza o pfSense 2.1.4 autenticado no AD ?



  • dgnonline

    Funciona belezinha tem alguns topicos aqui na comunidade que mostra passo a passo. se eu achar posto aqui pra vc.
    tanto no Win2008 e no Win2012 funciona bem
    os logs é só acompanhar os do squid.



  • Leia com atenção esse topico

    https://forum.pfsense.org/index.php?topic=76977.60

    Tem tudo ai.



  • Boa tarde davidjrsp,

    Hoje eu tenho um parâmetro que utilizo para autenticar no meu proxy (DEBIAN) … pretendo migrar a plataforma para o pfsense.

    auth_param basic program /usr/lib/squid/ldap_auth -R -b dc=empresa,dc=intranet -D cn=AD_READ,cn=Users,dc=empresa,dc=intranet -w SENHA -h x.x.x.x -p 389 -f "(&(objectClass=person) (sAMAccountName=%s))"

    No PfSense está da seguinte forma:

    LDAP Verion : 3
    LDAP server user DN : cn=AD_READ,cn=Users,dc=empresa,dc=intranet
    LDAP password: xxxxx
    LDAP base domain: dc=empresa,dc=intranet
    LDAP username DN Attribute : uid
    LDAP search filter: sAMAccountName=%s

    Será que não falta fazer algum outro ajuste apenas ? Algo que parecia ser tão simples :D

    No tópico em que você me passou o link, percebi que você utilizou parâmetros para consulta por grupos do AD, eu pretendo apenas usar a base do LDAP para autenticar, e configuro as restrições através do squidGuard.

    Quando tento navegar é solicitado o login e senha porem nos logs do squid aparece o erro de credencial, mesmo com usuário e senha correto.

    Log do squid:

    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'




  • verifique a senha de autenticacao, ela tem algumas restricoes de caracteres… por exemplo iniciar com caracteres especias.. @#$ na duvida use apenas letras e numeros, iniciando por letras..



  • Acabei de fazer um novo teste, criei um novo usuário faz parte do grupo "Read-only Domain Controllers". Com senha teste "Inicial2014" tbm não rolou  :o



  • eu uso usuario com permissao admin para acessar.. tente isso..



  • O problema continua :

    2014/08/15 16:08:09 kid1| Starting new basicauthenticator helpers…
    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'




  • Complementando.




  • parece que ele nao esta encontrando o user, a sua base DN e user DN estão corretos?

    no seu print o user DN esta faltando um DC no fim..

    abaixo segue print do meu




  • Bom dia Lucas,

    Consegui autenticar no AD.

    Muito obrigado pela ajuda, segui a mesma forma que vc passou os parâmetros e deu certo.

    Obrigado mais uma vez.



  • Complementando,

    Acho interessante criar um usuário para se autenticar na base LDAP do AD, que faça parte  apenas do grupo "Read-only Domain Controllers e Users". Para manter a infra menos vulnerável possível.

    Aqui está funcionando bala agora  ;)