Net6501-50 kingston ssd crash serial port not working



  • Hello

    I am desperated with this thing. After the recent update and reboot, the soekris does not come up anymore I get several IO errors on the kingston 32gb ssd

    ad6: TIMEOUT - READ_MUL retrying (0 retries left) LBA=4039135
    ad6: FAILURE - READ_MUL timed out LBA=4039135
    g_vfs_done():ufs/pfsense1[READ(offset=94445568, length=18944)]error = 5
    vnode_pager_getpages: I/O read error
    /etc/rc: /sbin/ldconfig: Input/output error

    I don't know what happened but it seems to me like the ssd is done for.

    The second issue I have got is, that I can not use the comport for some reason. It just does not take any input I type. I am using linux and minicom to access it, bautrate is correct as I see the output of the bootscreen but when ever I want to enter something, it just doesn't send keys. I know there was a possibility with switching off Hardware Flow Control, but I did that also and it didnt help… can anyone give me a hint why this is caused?



  • Hello, could someone please help?



  • Yes, I think this SSD is done for.  Best hope you have is to reinstall on a new SSD and restore your config.  I'm not sure why you are having serial port issues.  Have you tried booting from a new image (CD or memstick) ?


  • Netgate Administrator

    Was the serial console working before the crash?
    It sounds like you have a bad connection. You can see all the output if just 2 wires (Rx and Gnd) are connected but won't send anything and won't have any hardware flowcontrol.
    What are you able to see via serial exactly? BIOS output? Bootloader? Boot menu?

    Some Soekris boxes required DMA to be enabled in order to boot where as many embedded boxes won't boot with it enabled. That is the reason that the NanoBSD images have DMA disabled and the Nano+VGA images have it enabled. Since you're running a full install (are you? embedded kernel?) DMA should be enabled by default.

    Steve


  • Rebel Alliance Developer Netgate

    kingston ssd


  • Netgate Administrator

    Ha.  ;D
    I tend to agree although I think much of Kingston's bad rep here was down to their early small SSDs with bad firmware. The ssdnow range if I recall correctly.

    Steve



  • Hello sorry for the late reply I had given up the topic already.

    Anyhow, yes the serial was working once, I installed it on this. But I don't know if its the soekris or the usb serial adapter thats shitty. Sometimes I can type sometimes not. I tired minicom under Linux and Putty under Windows, see all output but have no input at all. I am now trying again with another ssd. Yes I had a full install on it.

    I can boot memstick after giving kernel console output with bautrate but I still have no input.
    When pfsense boots, WAN-port comes up and gets an IP but I can not access ssh or webinterface either (connection timeout on both).


  • Netgate Administrator

    It does sound like you have a bad connection somewhere.

    Steve



  • I'm interested in what kind of SSD was being run and if there was some sort of reliable wear leveling or trim?  If not - Wouldn't recommend running a full install like that again.



  • The ssd used for install was a ssdnow series drive sms100s2/32g

    I also don't understand why I get no input on the consoles. I tried three different USB-Serial adapters and three different computers, one with windows and putty and two with linux. I always get full normal output but can not type a key or command.


  • Netgate Administrator

    Bad console cable? Bad connector on the box?

    Steve



  • I don't know, I tried different adapters as said could be the cable but I have only one serial.

    Anyhow, when I manage to mount the SSD in another freebsd or pfsense, where do I find the configfile for the fullinstall version? i see there are /cf/conf but it is not a cf card…
    And is that on ad6s1a or ad6s2a partition? Both seem same


  • Netgate Administrator

    It's in the /conf folder. In Nano that's a simlink to /cf/conf because as you pointed out it's stored on a separate slice.

    Can you test your console cable on some other piece of equipment? Have you tried waggling it?  ;)

    Steve



  • This is probably a dumb question, but I know your drive was capable of trim but was trim set up on the pfsense?



  • trim: I didn't know of that feature, so if pfSense didnt set it by default, I probably didn't set it.

    About the slice:

    g_vfs_done():ufs/pfsense1[READ(offset=1024004096, length=35328)]error = 5
    vnode_pager_getpages: I/O read error
    vm_fault: pager read error, pid 296 (php)
    ad6: TIMEOUT - READ_MUL retrying (1 retry left) LBA=5854679

    So it seems that's the one with the error… I can mount ad6s1a without problems but ad6s2a won't allow me to mount it unless I set -o ro therefore I suppose that's the broken one.
    Unfortunately I have only one serial cable but three different usb. Their serial ends are male however, so I need a female-female cable to connect them with the soekris. I tried to get a console on another box (not soekris) but that didnt work either.



  • Yep - Not setting up TRIM will destroy your MLC drive in a hurry.

    These will last a good long time with no special treatment.  They are SLC

    http://www.ebay.com/itm/Intel-313-Series-SLC-SSD-Cache-24GB-mSATA-SSDMAEXC024G3H-HP-P-N-670071-001-/181509630521?pt=LH_DefaultDomain_0&hash=item2a42d12a39

    http://www.ebay.com/itm/111017164826?_trksid=p2060778.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT

    Try to find new spares if you can.

    Or, if you feel like playing with TRIM, any good new drive will work IF you enable TRIM.



  • Yes I will need some spares now, I will look your recommendations up and check into trim feature, thank you.


Log in to reply