• Help.  I changed domain names on my pfSense and now I'm locked out of my Web Configurator.

    • I changed the domain in System: General Setup

    • I updated all certs in my cert manager to the new domain and applied them

    • I imported the new certs to the machines I connect to my pfSense from

    • I updated all references of the old domain to the new domain in DNS Forwarder

    • I cleared all my browsing history

    • I closed and restarted my browser

    Now I get this.  Can anyone tell me why I'm suddenly getting this and how to fix it?  It actually appears to be coming from my proxy server.
    **ERROR

    The requested URL could not be retrieved**

    While trying to process the request:

    GET / HTTP/1.0
    Host: ffw.brossart.net
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,/;q=0.8
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36
    Accept-Encoding: identity,gzip,deflate
    Accept-Language: en-US,en;q=0.8
    Via: 1.0 pfSense:3128 (squid/2.7.STABLE9)
    X-Forwarded-For: 127.0.0.1
    Cache-Control: max-age=259200
    Connection: keep-alive

    The following error was encountered:

    • Invalid Request

    Some aspect of the HTTP Request is invalid. Possible problems:

    • Missing or unknown request method

    • Missing URL

    • Missing HTTP Identifier (HTTP/1.0)

    • Request is too large

    • Content-Length missing for POST or PUT requests

    • Illegal character in hostname; underscores are not allowed

    Your cache administrator is user@mail.com.
    Generated Sat, 16 Aug 2014 16:53:31 GMT by pfSense (squid/2.7.STABLE9)


  • Seems to be a Chrome thing.  I had the issue on IE briefly, but now IE is getting to the GUI just fine.

    Would still appreciate advice to fix Chrome.

    Thanks.


  • Problem solved.  Proxy configuration.  Since I'm running on an APU4, I'm running nanobsd.  Since I'm running nanobsd, I have Hard Disk Cache set to Null (i.e. no disk cache).  I had values in some of the variables specifically dealing with disk cache.  I figured it was a moot point because my Hard Disk Cache was set to Null.  It looks like these values were causing Squid to think there was disk cache, and when it tried to retrieve it, nothing was there and I got the error.  I changed the settings such that Squid would only ever look to memory for cache et voila!  It works great.