Haproxy freeze during installation " HAProxy, update configuration"



  • Hello ,
    I hope this is the right forum for this .
    I tried to install the Latest HaProxy package (1.5.3 pkg v 0.10) which is in production environment  , The package simply stuck in the middle of installation i was hoping maybe you know how to solve this issue .

    Problem :
    I had a older version of HAproxy which installed 3 months ago , I tried to re-install the package but package installer simply stuck on " HAProxy, update configuration" and that's it i don't see the Haproxy on the " Services" menus but i can see the package installed !!!

    Loading package instructions…
    Custom commands...
    Executing custom_php_install_command()...HAProxy, running haproxy_custom_php_install_command()
    HAProxy, conf_mount_rw
    HAProxy, create '/usr/local/etc/rc.d/haproxy.sh'
    HAProxy, update configuration

    Any idea how to troubleshoot this issue .

    Many thanks in advance and i would appreciate your prompt response .



  • Where you already running a haproxy-devel 1.5dev versions before or the stable 1.4 ?

    For a possible easy solution you might try uninstalling the package, and then installing it again.
    If that doesn't work, download a config backup, remove the <haproxy>section and restore the config file (make sure you know how XML should be formatted). Then try to install again..

    As for troubleshooting it would be nice if you could change the /usr/local/pkg/haproxy.inc file and include some more lines with 'debugging' info like this between where that last line of logging is generated, and where the next one doesn't show.:

    
    $static_output .= "HAProxy, debugging step 1\n";
    update_output_window($static_output);
    
    

    Then from a developer shell option 12 on the console run these commands:

    global $pkg_interface;
    $pkg_interface = "X";
    include_once('haproxy.inc');
    haproxy_custom_php_install_command();
    exec
    
    

    And check the output generated to at which debugging step the processing 'stops'.. Then please report back.</haproxy>


Log in to reply