Run from USB NOT install from USB



  • I've been searching for days on how to setup and run pFsense from a USB. I find how to install from USB, but not what I'm trying to do.

    So I downloaded the memstick version. I used win image tool to write it. I boot up on USB and when I try to install it.. 99  all hell breaks loose. I get errors. I'm thinking it's trying to install it somewhere else and can't find it.  I run pFsense at my house, but want to run it totally off a Flash Drive now and just can't seem to find any information on this.  Here are some errors I get after hitting 99:

    Execution of the command
    /sbin/fdisk -I da0
    FAILED with a return code of 1

    Now this is in the error log at the bottom.

    Flow executing - > main/install/select _disk (Select Disk)
    Flow executing - > main/install/format_disk (Format Disk)
    -<<< Excuting '/usr/sbin/cleargpt.sh da0"
    : gpart: Device busy
    : gpart: Invalid value for 'i' argument: Invalid argument
    : gpart: Device Busy
    '->>> Exit status: 0
    -<<< Executing '/sbin/fdisk -I da0
    ******** Working on device /dev/da0 *************
    : fdisk /boot/mbr: No such file or directory
    ->>> Exit status: 1

    Maybe I'm over looking something? Do I install it from CD to USB?  Just need be pointed in the right direction doesn't seem to be too much information on the internet about doing this.

    Thanks,
    Rick





  • They seem to be talking about Booting issues. It boots just fine and runs. But every time it reboots I have to re-set it up. I need it to install and run from USB.



  • You have to take the nano image and write it to the USB and you are done, no installation needed… read the link ;-)



  • Did that, but now I get disk is full?

    Filesystem        1K-blocks  Used  Avail Capacity  Mounted on
    /dev/ufs/pfsense0    453327 453281 -36219  109%    /
    devfs                    1      1      0  100%    /dev
    /dev/ufs/cf          50527  1162  45323    3%    /cf
    /dev/md0              39406    450  35804    1%    /tmp
    /dev/md1              59246  18104  36404    33%    /var
    devfs                    1      1      0  100%    /var/dhcpd/dev
    /dev/md10            469934      6 432334    0%    /var/tmp/havpRAM



  • I took the 4GB nano image and a 8GB stick, worked fine. And you? ;-)



  • smh@myself  Helps if I download the 4 gig instead of the 1 gig image.



  • I've been running the full install on USB for couple years now.

    It's been a while but think I installed from booted USB image to another USB device.  (install image on one usb device, and install to another usb device).  Can't install to the USB image device booted from.

    Another way is to install to USB device from booted CD image.

    Running full version on USB mem stick it is a good idea to configure /tmp & /var to use ram disk.



  • I'm using the 1G image on an 8G flash drive.

    Did you try a different brand of stick? There are a few that don't work well, for some OS's anyway.