Squidguard url-rewrite for Google safe search?



  • I download and configured Squid and Squidguard in order to use Pfsense as a url-rewrite proxy, but haven't had any luck in getting url-rewrite to force Google Safe Search.  I tried the built in option that was supposed to cover Google and several other search engines and got no dice.  Does anybody have a sample config for Squidguard that does work properly?



  • Their is option in SquidGuard to enforce safesearch for Google, Yahoo and Bing. Just check the option and it'll be enforced.



  • No, it is not working.  I do have the "Use SafeSearch engine" check box checked and I have restarted squid multiple times.  No evidence that any of the url-rewrites are working.  Is there something else that I need to do?  Either there is something else beyond restarting squid that needs to be done or the built in option doesn't appear to work.  I have tried completely restarting Pfsense completely and same result.  I've tried various custom rewrite conf that I have found others suggest and they don't work either.

    For reference since I forgot to mention in in the initial post.  I have Squid 3.3.10 and SquidGuard 1.4_4 v.1.9.5.  If somebody has a known functional setup please I would be interested in how you configured your setup (versions used, any custom config, etc.).



  • Safesearch may not work due to changes made ​​by the developers of search engines. This part of the code has not been updated in a package for a long time, and therefore may not be relevant. Why is it so is another question ..



  • I was helping someone just the other day with this very issue.  SafeSearch via SquidGuard works fine.  With it enabled, I couldn't get to any spicy Google images, and any attempts to turn off the filter just dropped you on the Google main page.



  • @KOM:

    I was helping someone just the other day with this very issue.  SafeSearch via SquidGuard works fine.  With it enabled, I couldn't get to any spicy Google images, and any attempts to turn off the filter just dropped you on the Google main page.

    Did you do anything beyond clicking the checkbox?  In addition, what version of squid/squidGuard were you running?



  • @SAugsburger:

    Did you do anything beyond clicking the checkbox?  In addition, what version of squid/squidGuard were you running?

    Did you check both the "Enable Safe Search" option and also the "safesearch" option in rewrite dropdown in the common acl as well?



  • @networkinggeek:

    @SAugsburger:

    Did you do anything beyond clicking the checkbox?  In addition, what version of squid/squidGuard were you running?

    Did you check both the "Enable Safe Search" option and also the "safesearch" option in rewrite dropdown in the common acl as well?

    I have both the enable safe search option and the rewrite dropdown selected, I saved the changes and I already restarted squid.  SquidGuard shows as running as well.  Still no dice.



  • @SAugsburger:

    I have both the enable safe search option and the rewrite dropdown selected, I saved the changes and I already restarted squid.  SquidGuard shows as running as well.  Still no dice.

    I just tried it with squid3 and squidguard-squid3 package. Safesearch is working fine with bing and yahoo. Google is showing that safesearch is enabled but it pops up the results even for the loaded terms. May be it is looks for certain patterns and filters the results depending on the regional domains (Well this I what i think and I may be wrong).



  • In addition, what version of squid/squidGuard were you running?

    I don't remember if it was 2 or 3, but it was NOT Squid3-dev.



  • @networkinggeek:

    @SAugsburger:

    I have both the enable safe search option and the rewrite dropdown selected, I saved the changes and I already restarted squid.  SquidGuard shows as running as well.  Still no dice.

    I just tried it with squid3 and squidguard-squid3 package. Safesearch is working fine with bing and yahoo. Google is showing that safesearch is enabled but it pops up the results even for the loaded terms. May be it is looks for certain patterns and filters the results depending on the regional domains (Well this I what i think and I may be wrong).

    Depending upon how the regular expression is written it may not apply to all versions of Google and Google may use slightly different syntax in different international versions.  I recognize that, but I can't get it to work with any version afaik.  I recognize one can't be perfect, but even basic functionality doesn't appear to be working here at least for me anyways.



  • Anybody have any ideas?



  • I can't get it to work either



  • Possibly the rewrite works as expected but then Google redirects the request to SSL, whereupon (without further tech) the rewrite isn't possible. You can workaround the SSL redirect by creating CNAME records for all Google domains you allow, pointing at nosslsearch.google.com.

    Rumours are that there is known way to circumvent that method, so can also try accepting the SSL but using the CNAME record method to force safe search forcesafesearch.google.com.

    Or just ban Google for being idiots and forcing SSL and use Bing instead.


Log in to reply