Transparent Proxy'ing IPv6



  • Allo,

    I have transparent proxy working just fine for IPv4 machines sitting behind my firewall, but IPv6 aren't catched. Also, I don't see any listen on IPv6 addresses on my firewall:

    [root@CPE000db934c395-CM002624e8c9e0:cache]# netstat -an | grep 3128
    tcp4       0      0 127.0.0.1.3128         *.*                    LISTEN
    tcp4       0      0 10.0.2.1.3128          *.*                    LISTEN
    tcp4       0      0 10.0.1.1.3128          *.*                    LISTEN
    [root@CPE000db934c395-CM002624e8c9e0:cache]#
    

    However, on the Real Time tab, I do see IPv6 targets when the proxy is able to reach the target thru IPv6 (for example, google.com, or facebook.com) for IPv4 machines sitting behind my firewall.

    IPv6 is working just fine for all my two LANs.

    Why is it squid not listening on IPv6 firewall ports? And also, transparently proxy'ing ports targets 80 also on IPv6 machines?

    I'm running squid3.



  • It seems that if I add

    http_port [2001:xx:xx:94a::1]:3128
    acl localnet src 2001:xx:xx:94a::/64
    

    Into the Custom options on the General tab it nows listen to the ipv6 IP correctly.  However, the transparent proxying on ipv6 doesn't seem to work.