Multiple physical LANs with NAT to one WAN



  • Hello I am having trouble getting multi LAN single WAN working. I have tried automatic NAT and aon and nothing works. I am rebooting after changes to make sure things take effect. If I am using for example LAN2 the internet will work for a minute or two and then stops. The LAN connection works fine no matter what is set. I have included a screenshot of the aon settings I have. Does anyone know what the deal is?
    ![Screenshot - 08242014 - 03:12:14 PM.png](/public/imported_attachments/1/Screenshot - 08242014 - 03:12:14 PM.png)
    ![Screenshot - 08242014 - 03:12:14 PM.png_thumb](/public/imported_attachments/1/Screenshot - 08242014 - 03:12:14 PM.png_thumb)


  • Rebel Alliance Global Moderator

    So you lan is 192.168.5.0/27 ??  Just let pfsense automatically set your nat.  Your missing local nat there, did you delete it?

    Lets see your other intefaces setup really your running a /30 on your opt interface?



  • @johnpoz:

    So you lan is 192.168.5.0/27 ??  Just let pfsense automatically set your nat.  Your missing local nat there, did you delete it?

    Lets see your other intefaces setup really your running a /30 on your opt interface?

    Yes my LAN is a /27 just enough for my devices and a few extra not sure why just did it because. The opt interface doesn't have a switch or anything on it, just one device so there is no need for another address. I don't remember deleting anything, but I guess it is possible. I currently have automatic nat on and it still isn't working. What interface setup are you wanting to see? LAN2 is set static IPv4 and DHCP is set up.


  • Rebel Alliance Global Moderator

    so you only have 1 device on this opt interface - can it ping pfsense IP on that interface?

    When you switch from auto to manual – all the automatic nats should be listed.  But yours looked to be all manually configured.  There should be stuff for the local to wan, and there should be statics for the 500, etc.  So lets verify you didn't typo a mask or something or have something overlap?

    Auto really should just be left on unless you have some really oddball stuff to do, etc.

    So what does this device do when you do a trace.  What do you see on a sniff of the interface, etc.  Does the device mask match? etc..



  • @johnpoz:

    so you only have 1 device on this opt interface - can it ping pfsense IP on that interface?

    When you switch from auto to manual – all the automatic nats should be listed.  But yours looked to be all manually configured.  There should be stuff for the local to wan, and there should be statics for the 500, etc.  So lets verify you didn't typo a mask or something or have something overlap?

    Auto really should just be left on unless you have some really oddball stuff to do, etc.

    So what does this device do when you do a trace.  What do you see on a sniff of the interface, etc.  Does the device mask match? etc..

    Okay I got it fixed.

    I deleted all of the NAT rules that I had, and then re-enabled aon and I saw all of the rules you mentioned. I tried with it set on aon and I tried automatic still didn't work. Reboots in between each setting change, nothing.

    I found a backup from before I followed this guide. http://www.retropixels.org/blog/use-pfsense-to-selectively-route-through-a-vpn and now everything works when set to automatic. I believe that the order in which I added rules manually was why the automatic rules weren't displayed. Thanks for you help. Not sure if this is a bug or not? It was like the rules didn't really reset or something when switching back to automatic.