Squid, WiFi, and "Sign in required"



  • I recently tested out squid 3, and had issues where phones and a few laptops would gripe that the wireless required sign-in (it doesn't), So I removed squid 3 and went back to squid 2.

    The issue is that this "Sign-in Required" issue still persists.  Is there something that Squid3 did that was left behind, or some setting that I need to check and fix?

    It's quite annoying, and oddly it's booting people off of the wireless.

    For further information, when you press the option to "sign in" it just takes to a squid error page.
    To make things even more frustrating, I told squid to bypass the ip range for wifi, and it still persists.


    [[Solved]]
    Problem: Squid is stupid when on the same box and you have Multi-Wan.  I don't feel like hacking it to pieces with the scattered as heck information all over the forums
    Resolution: remove squid until I can put it on its own special box.

    [Update]
    Actually I think it might be more than this.  Apparently there is something making the firewall go bat-s**t crazy with Multi-Wan since I updated it.

    One of my links isn't responding like it should (have a bad line and techs should be out soon to repair), so the link is unstable.  I noticed that the gui gets unresponsive and even with squid completely removed, I'm noticing apinger is falsely reporting WAN has 28% packetloss when I know otherwise from testing.  Seems that if I disable the OPT1 interface, the whole system and squid start working fine, and apinger reports correct line quality.

    Still doesn't explain why wireless acts stupid with squid running and multi-wan, but… I give up for now.