Squid Automatically Generating



  • Hello, all!

    I just installed Sarg a few days ago, and have really been liking the detail of information.

    Unfortunately, the logs are being rotated every day at midnight. I would like them to rotate once per week…

    I turned off log rotation in Sarg, Squid, and Squidguard. I even disabled and re-enabled the logging function to see if that would clear it out. Unfortunately, the rotation still occurs. I went into Cron, and it showed that there was a scheduled task to rotate the logs every night at midnight. I deleted the task, and re-enabled logging, and log rotation once per day in Squid. Upon saving, the task was re-generated to run at midnight every night.

    This is the task that keeps regenerating whenever I save changes to Squid:

    0  	0  	*  	*  	*  	root  	/usr/pbi/squid-i386/sbin/squid -k rotate -f /usr/pbi/squid-i386/etc/squid/squid.conf
    

    Any idea how to prevent this from happening?

    Thanks!
    ElectroPulse