Packages list on www.pfsense.com



  • Can it be done easily to list the available packages on a separate page of the pfsense web site?
    Some table like package name and description derived fom the actual .XML?

    Could be helpful for newbies when they have not set up an install with INet access yet.



  • If a stylesheet directive could be added to the XML at http://www.pfsense.com/packages/pkg_config.xml, then it would show formated in a human readable page.

    Anybody handy with XSLT?  Adding that directive to the XML file should not have any effect on the processing of the package information.



  • Greetings all,

    As I continue to become proficiant in pfsense I find myself now wanting to understand what packages/plugins may be available for this which is a feature I love about IPCop…. lots O' packages for that system which makes it very desirable.

    In my efforts to understand what packages are available I have found that I can find nothing anywhere which lists the packages available, any description to know what it is they do, and any place to actually download them.  Seems to me that this would be a very desirable capability to expand the awarness/use of pfsense.

    Am I overlooking something here?

    ..... UPDATE

    ok... I believe I found a 'directory' of packages however it seems to be just that... a directory.  http://www.pfsense.com/packages/All/

    Doesn't seem to be anything that suggests what does what other than what one might be able to decipher from the name of the file.

    Thanks



  • Forget about the link you posted, that's a different story.

    Heiko was so kind to take screenshots of the package section within pfSense recently (for later reference: 02/2008; 1.2RC4)
      http://forum.pfsense.org/index.php/topic,7736.msg43634.html#msg43634

    Note that these packages can only be found from the pfSense webGUI. (That's why I asked if someone can make a web page of it)



  • Okie dokie,

    I now understand from the post above that my pfsense boxes have not been able to retrieve the package list… both of them give this response when going to the packages screen.....

    "Unable to communicate to pfSense.com. Please check DNS, default gateway, etc."

    I have valid DNS entries along with gateway references and these two boxes are live providing routing functions for two networks.

    Any comments?

    Thanks again.



  • I have seen this issue before (several time in fact) but have not figured out the cause - I have had pfsense boxes running and able to ping the packages site but still no joy… one of life's strange mysteries I guess ;)

    You might double-check the DNS settings you are using and make sure you have it configured properly - or - if you are using DNS to obtain your WAN side connection make sure you don't have DNS setup otherwise you may be overwriting the DNS settings from the DHCP server at the far end (that bit me once).

    gm...



  • @hdokes:

    Okie dokie,

    I now understand from the post above that my pfsense boxes have not been able to retrieve the package list… both of them give this response when going to the packages screen.....

    "Unable to communicate to pfSense.com. Please check DNS, default gateway, etc."

    I have valid DNS entries along with gateway references and these two boxes are live providing routing functions for two networks.

    Any comments?

    Thanks again.

    What do you get when you browse http://www.pfsense.com/pfSense/pkg_tester.php ?



  • Here is what shows from the link above:

    Array ( [siproxd] => Array ( [name] => siproxd [version] => 0.6.0 ) [OpenBGPD] => Array ( [name] => OpenBGPD [version] => 0.3 ) [Dyntables] => Array ( [name] => Dyntables [version] => 1.0 ) [lightsquid] => Array ( [name] => Lightsquid [version] => 1.7.1_1 ) [Developers] => Array ( [name] => Developers [version] => 0.1 ) [Dashboard] => Array ( [name] => Dashboard [version] => 0.6.2 ) [phpSysInfo] => Array ( [name] => phpSysInfo [version] => 2.5.3 ) [dns-server] => Array ( [name] => dns-server [version] => 1.0.2 ) [arping] => Array ( [name] => arping [version] => 2.05 ) [frickin] => Array ( [name] => frickin [version] => 2.0-BETA2 ) [bsdstats] => Array ( [name] => bsdstats [version] => 3.9 ) [clamav] => Array ( [name] => clamav [version] => 0.1 ) [phpmrss] => Array ( [name] => phpmrss [version] => 0.13 ) [p3scan-pf] => Array ( [name] => p3scan-pf [version] => 0.1 ) [clamsmtp] => Array ( [name] => clamsmtp [version] => 0.1 ) [viralator] => Array ( [name] => viralator [version] => 0.1 ) [nmap] => Array ( [name] => nmap [version] => 4.20_1 ) [snort] => Array ( [name] => snort [version] => 2.7.0.1_3 ) [miniupnpd] => Array ( [name] => miniupnpd [version] => 20080130 ) [imspector] => Array ( [name] => imspector [version] => 0.3.1 ) [nut] => Array ( [name] => nut [version] => 2.0.4 ) [diag_new_states] => Array ( [name] => diag_new_states [version] => 0.2 ) [freenas] => Array ( [name] => freenas [version] => 0.68 ) [dspam] => Array ( [name] => dspam [version] => 3.6.8 ) [sshterm] => Array ( [name] => sshterm [version] => 0.1 ) [spamassassin] => Array ( [name] => spamassassin [version] => 0.1 ) [darkstat] => Array ( [name] => darkstat [version] => 3.0.619 ) [ntop] => Array ( [name] => ntop [version] => 3.2_2 ) [pfflowd] => Array ( [name] => pfflowd [version] => 0.6 ) [widentd] => Array ( [name] => widentd [version] => 1.03_1 ) [freeradius] => Array ( [name] => freeradius [version] => 1.1.2_1 ) [bandwidthd] => Array ( [name] => bandwidthd [version] => 2.0.1.1 ) [stunnel] => Array ( [name] => stunnel [version] => 4.18 ) [iperf] => Array ( [name] => iperf [version] => 2.0.2_1 ) [netio] => Array ( [name] => netio [version] => 1.14 ) [ifdepd] => Array ( [name] => ifdepd [version] => 20050420 ) [mtr-nox11] => Array ( [name] => mtr-nox11 [version] => 0.65_2 ) [squid] => Array ( [name] => squid [version] => 2.6.5_1-p15 ) [LCDproc] => Array ( [name] => LCDproc [version] => lcdproc-0.5.2_1-p4 ) [arpwatch] => Array ( [name] => arpwatch [version] => 2.1.a13 ) [routed] => Array ( [name] => routed [version] => 1.1 ) [squidGuard] => Array ( [name] => squidGuard [version] => 1.2.0_1 ) [Zabbix Agent] => Array ( [name] => Zabbix Agent [version] => 0.1 ) )

    This is via my firefox behind the pfsense box.  Is there a way to exercise this from the pfsense box.  I should add here that both pfsense boxes are of the embeded flavor on a 2gb cf card.



  • Argh, embedded systems don't support packages, hence they are not shown, IMHO.
    Installing a package on such a system might be doable but is NOT supported in any way.



  • I have this problem occuring with a new install of 1.2-RC4 that I was planning on using as a home firewall. Its hosted on a virtual machine with bridged network card/vmnet adaptors, computers behind it can navigate fine, but the webgui reports back
    "Unable to communicate to pfSense.com. Please check DNS, default gateway, etc." when i go to the packages page.
    output from a computer behind firewall for the pkg_tester page

    Array ( [siproxd] => Array ( [name] => siproxd [version] => 0.6.0 ) [OpenBGPD] => Array ( [name] => OpenBGPD [version] => 0.3 ) [Dyntables] => Array ( [name] => Dyntables [version] => 1.0 ) [lightsquid] => Array ( [name] => Lightsquid [version] => 1.7.1_1 ) [Dashboard] => Array ( [name] => Dashboard [version] => 0.6.2 ) [phpSysInfo] => Array ( [name] => phpSysInfo [version] => 2.5.3 ) [dns-server] => Array ( [name] => dns-server [version] => 1.0.3 ) [arping] => Array ( [name] => arping [version] => 2.05 ) [frickin] => Array ( [name] => frickin [version] => 2.0-BETA2 ) [bsdstats] => Array ( [name] => bsdstats [version] => 3.9 ) [clamav] => Array ( [name] => clamav [version] => 0.1 ) [phpmrss] => Array ( [name] => phpmrss [version] => 0.13 ) [p3scan-pf] => Array ( [name] => p3scan-pf [version] => 0.1 ) [clamsmtp] => Array ( [name] => clamsmtp [version] => 0.1 ) [viralator] => Array ( [name] => viralator [version] => 0.1 ) [nmap] => Array ( [name] => nmap [version] => 4.20_1 ) [snort] => Array ( [name] => snort [version] => 2.7.0.1_3 ) [miniupnpd] => Array ( [name] => miniupnpd [version] => 20080130 ) [imspector] => Array ( [name] => imspector [version] => 0.4 ) [nut] => Array ( [name] => nut [version] => 2.0.4 ) [diag_new_states] => Array ( [name] => diag_new_states [version] => 0.2 ) [freenas] => Array ( [name] => freenas [version] => 0.68 ) [dspam] => Array ( [name] => dspam [version] => 3.6.8 ) [sshterm] => Array ( [name] => sshterm [version] => 0.1 ) [spamassassin] => Array ( [name] => spamassassin [version] => 0.1 ) [darkstat] => Array ( [name] => darkstat [version] => 3.0.619 ) [ntop] => Array ( [name] => ntop [version] => 3.2_2 ) [pfflowd] => Array ( [name] => pfflowd [version] => 0.6 ) [widentd] => Array ( [name] => widentd [version] => 1.03_1 ) [freeradius] => Array ( [name] => freeradius [version] => 1.1.2_1 ) [bandwidthd] => Array ( [name] => bandwidthd [version] => 2.0.1.1 ) [stunnel] => Array ( [name] => stunnel [version] => 4.18 ) [iperf] => Array ( [name] => iperf [version] => 2.0.2_1 ) [netio] => Array ( [name] => netio [version] => 1.14 ) [ifdepd] => Array ( [name] => ifdepd [version] => 20050420 ) [mtr-nox11] => Array ( [name] => mtr-nox11 [version] => 0.65_2 ) [squid] => Array ( [name] => squid [version] => 2.6.18 ) [LCDproc] => Array ( [name] => LCDproc [version] => lcdproc-0.5.2_2 ) [arpwatch] => Array ( [name] => arpwatch [version] => 2.1.a13 ) [routed] => Array ( [name] => routed [version] => 1.1 ) [squidGuard] => Array ( [name] => squidGuard [version] => 1.2.0_1 ) [Zabbix Agent] => Array ( [name] => Zabbix Agent [version] => 0.1 ) )

    From firefox
    As far as I know I did not install the embedded version… Any way to tell?



  • which platform: the index page has a platform line-> pfsense or embedded.


Locked