Squid error with gui and acl localnet

  • I recently setup pfsense for the first time with squid 3.3 i finally got it all up and running with diladele in transparent mode. All is well except for when rebooting or sometimes restarting the squid service it would stop restarting. I found out it was and invalid acl localnet in the config, i would have this next to my subnet  which is wrong.

    So i delete it from the config, it would then  start. This works untill i need to reboot or restart.

    Things i have tried so far.

    • removing all entries in acl subnet gui and restarting
    • removing and installing squid package.

    Anyone have any ideas?

  • I have narrowed it down to my openvpn interface (OPT) being enabled in the gui as a transparent interface, giving the weird address.

Log in to reply