[Fixed] Nano image is actually nano+vga again.


  • Netgate Administrator

    Just tried for the second time to upgrade my home box which is running the 1G Nano image. Don't know what happened the first time since I hit upgrade and went to dinner, it didn't upgrade. Second time it successfully downloaded and applied the image but when it rebooted it never came back up. After I'd dug out my console cable I found the upgraded slice was nano+vga and it was failing with a DMA error. My box doesn't support DMA.
    Looking in https://updates.pfsense.org/_updaters/ the 1G Nano image is what is listed as Nano+VGA on the mirrors. Isn't this the same thing that happened with 2.1.4?

    Steve



  • My 2.0.2 Alix / nano upgrade just now did not come back after its upgrade.

    Of course it's in a location 600 miles away in a non staffed site.

    My other 2 Alix sites at 2.1.4 came up fine.

    At least I know a path to attempt diagnosis



  • I upgraded a nano 2g version With vga but the console version appeared to be installed.  Thought I would post this to pass along, something seems to not match up.

    No big deal since these were testing boxes.



  • i was on 1g nano serial console, upgraded and it installed nano with vga, booted fine but i still prefer the console version.
    under settings there is option to switch to serial console from vga, applied it but still cant do anything from the serial console.



  • tried upgrade from url using serial console and url of upgrade image from mirrors and worked well



  • I am continuing to have problems with this upgrade, both attempting through the GUI and the command line update tool. I am running a watchgaurd X750e with a 4GB CF. The update installs and it reboots but it doesn't come back online. I can get it to boot again by having it boot 1 instead of 2 at the prompt.

    Not sure if this is related, but just before the reboot there is an error on the console "/var: write failed, filesystem is full", but running "df -hi", doesn't show anything of concern. This compact flash card is only a month old, so I would find it hard to believe it is going bad already.

    Thank you for any assistance.



  • I guess it will piss everyone off if I say "only run full installs"?  When separated by half a world from my box, I don't trust anything else when upgrade day arrives.



  • i upgraded 6 boxes today using console method and worked fine



  • I had a few hours of down time today due to a non booting upgraDe same as steven. Screwing up the images once was bad enough, seems they didn't learn from their mistakes. Very annoying


  • Netgate Administrator

    It was bad enough for me trying to connect my console cable behind the fridge (don't ask  ::)) at 2am but at least it was in the same building.
    It's worth noting that, as before, this is only an immediate problem on boxes where the CF card slot doesn't support DMA. The Nano+VGA image doesn't have DMA disabled where straight Nano does so the box fails to boot with DMA errors. I thought the Alix has this issue though and I'm almost certain the upgrade images will have been tested on that.  :-\ I guess the problem is with whatever script copies the images to the update server.

    Steve



  • Upon reading additional comments, I was able to get 2 more devices to complete with success. I had to manually input the URL to the correct version on the command line but both completed successfully. The one using a 2G image though says 2.1.5 but shows there is a newer version available, which seems odd.



  • Same here, seemed to stop responding after upgrade. Freezing on console after boot menu counted to zero or an option was chosen.
    Restarted the x550 twice then tried safe mode which worked but now console is broken.

    Will diagnose later as I've had to leave for a few hours.

    Pete



  • Just upgraded through console. I found the console worked at 9600 instead of what it was supposed to be at (115200).

    Web manual update just locks up.

    I installed the latest from the mirrors, not the updates:
    http://files.bgn.pfsense.org/mirror/updates/pfSense-2.1.5-RELEASE-1g-i386-nanobsd-upgrade.img.gz

    (used local mirror.)

    It works now but boots up at 9600 then switches to 115200.

    Guess from now on, I'll be upgrading through the console and manually pick the update.


  • Netgate Administrator

    For anyone who has been hit by this you can recover by connecting to the serial console at 9600 (the bootloader is always 9600) and select the previous boot slice at the menu by hitting '1' or '2'. You will then be returned to your previous pfSense version where you can upgrade manually by downloading the correct image from the mirrors or wait until the correct image is on the updates server.

    Steve


  • Netgate Administrator

    Ok, the update server now seems to have the correct images on it. The 1G image worked fine for me anyway.
    Interestingly it's a different file to the upgrade images on the mirrors, different md5 sum.

    Steve



  • I try to upgrade (2.14) using the web interface ( autoupdater )but for this one is not working, it stop after it finish the download.
    :(
    My Alix don't like this update ;)


  • Netgate Administrator

    Well the fault documented in this thread has been fixed so it's not that.
    The Alix can struggle with memory during upgrades. Are you running packages? Lots of interfaces? What CF size? Did it just fail to upgrade or crash out somehow? Anything in the logs, particularly the NanoBSD upgrade log in Diagnostics: NanoBSD:?

    Steve