SquidGuard time source??



  • Even though the "date" command at my pfSense console shows the correct date and time, SquidGuard does not seem to use that date or time.  I noticed originally that the times I set up were not being honored.  Then when looking at the log the time and date was way off the mark.  The date was literally almost 4 months off and the time is about 10 hours off.  Is this a bug?  Can anyone confirm what I'm seeing?  All you need to do is look at the time stamps on your log.



  • I have all correct. Date, GUI log and squidGuard log contain the same date/time.



  • I did figure out that the date is actually right, it is just formatted differently than I am used to.  I use MMDDYYYY while SquidGuard is using DDMMYYYY.

    The time however is 10 hours ahead of my time.  I have my router set for EST which is GMT-5.  SquidGuard seems to be displaying GMT+5.  So, I did a bit of experimenting with time zones, and apparently it is totally backwards.  When I set my router to Etc/GMT-5, it sets the time at Etc/GMT+5 and vice versa.  The only time zone that appears right is Etc/Greenwich because it is neither + nor -.  This seems to be a bug in 1.2RC3.  Now, if I set the time zone to EST (which is my zone), the router has the right time and date when using the DATE command, but SquidGuard is showing GMT+5 (which is wrong).  It should be showing GMT-5, but since the router is showing all the GMT times backwards, so is SquidGuard.  Can you confirm this?  Something is certainly weird.  If you use standard time zones that start with Etc/GMT, everything is backwards.  If you use location specific time zones such as EST, the router displays the right time, but SquidGuard still shows the backwards time zone associated with the location time zone (for example, EST is Etc/GMT-5 but when choosing Etc/GMT-5 the time is displayed as Etc/GMT+5).

    Chris



  • Thanks for you researching I analyse you information.



  • I found this - error time only in GUI log.
    squidGuard take correct time (/var/squidGuard/log/squidGuard.log).
    This is my bug in php source, and it does'nt influence anything.



  • The error expands past SquidGuard.  It is also affecting the router.  When running the "date" command at the console the response is wrong.  I believe this error is more than just your PHP code.  The whole reason I have been looking into this is because SquidGuard is ignoring my time rules, but I think ultimately the time is just wrong on the router.



  • squidGuard_configurator.inc

    function sg_addlog($log) {
             setlocale(LC_TIME, '');
    
             global $squidguard_config;
    


  • Can you elaborate?  That code means nothing to me.  I don't speak PHP.  :-)

    Chris



  • @ciarocci:

    Can you elaborate?  That code means nothing to me.  I don't speak PHP.  :-)
    Chris

    Near time will updated.



  • Update squidGuard sources. Fixed rebooting start SG bug and small blacklist fixes.



  • I just installed the latest version of SG, and now it's all broken and locking up my router.  Running TOP and the SSH console shows 6 instances of SG running that are sucking up all the processor.  After a while that subsides (mostly) but SG is blocking nothing at all at this point.  I can get to any website I want.  When someone goes on the web, SG suddenly uses up all the processor again for a while.  Also, I noticed the time in the log is still 10 hours off.

    Update:

    Uninstalling Squid, and SG, then reinstalling Squid, then SG and pushing the save button in SG so it accepted the defaults seems to have fixed my locking up problem.  Then I was able to re-configure SG and it worked.  However, SG is still ignoring my times and the log is still showing 10 hours ahead of my local time.



  • I update SG gui (XML) - reinstall and test this
    ps
    Do not press Update blacklist button more what once at 30 minute
    Script very long time to rebuild
    Near time i adding fix for kill old runing script's



  • OK, I uninstalled and reinstalled today.  After reinstalling I created a simple 1 URL destination.  I then created a simple time called Business Hours.  I went to the default tab and set the default time to Business Hours.  I then put a check next to the destination I created, and deny.  I clicked the save button, then went to the general tab and clicked Apply.  After doing that I then tried to get to the site, and I could without any problem.  I then went back, checked Deny on the overtime side, and saved then applied.  Now the site is blocked.

    Still SG is still ignoring the times I set.  It seems like nothing has changed since I first reported the problem.  Please help.  My boss is complaining and giving me a headache.  :-)  What can I do to test further and get this issue resolved?

    Thanks.

    Chris



  • Reinstall you SG - soures updated.
    Default page worked without times (this option now deleted)
    You can create ACL rule with time option
    Please check this and replay result :)
    I tested - this worked for me (only check you time-zone).
    Current date-time you can view from putty cmd

    date

    ps Also added new SG options in ACL's - 'Not to allow IP addresses in URL'



  • I installed the new version.  Using an ACL for the site I need to be blocked at certain times still does not work.  The site is blocked 24/7 even though I have it blocked only during business hours.



  • Do you have SG log/config ?



  • Sent you 2 PMs with info



  • properly configuring the ACL solved the problem.  a small suggestion, put something in the html that checks for required info, or at least a warning saying a particular entry is required.  it would help newbs like myself when trying to configure things.

    thanks again.



  • This will is added in. Last time very many was changed.


Locked