Unbound with split horizon - is it possible?



  • I have been experimenting with unbound on 2.1.5 and I'm having problems recreating the split horizon DNS setup I have been using for years with dnsmasq (DNS Forwarder), /etc/hosts and an externally hosted DNS.

    I cannot resolve hostnames in my RFC1918 private address space but those in the external DNS resolve nicely. The RFC1918 hostnames appear to be listed in unbound's cache but they wont resolve for client requests.

    Anyone having the same problem?



  • I ran into this same issue experimenting with unbound.  First I would confirm that unbound is able to answer the query.  Use 'dig <hostname>@<pfsense_lan_ip>' from a computer on the LAN.

    If that returns the correct response then you probably are running into the same thing I ran into.  With the default dns forwarder disabled the dhcp server was giving clients the dns servers listed in the general setup.  I had to explicitly put the LAN ip in the dns server dhcp server setting.

    David</pfsense_lan_ip></hostname>