[Resolvido] Captive portal com Radius



  • Bom dia, atualmente estou tentando autenticar meu portal com os usuários do meu AD. Segui o seguinte tutorial para criação tanto do meu portal quando do meu servidor Radius :

    https://forum.pfsense.org/index.php?topic=56238.0

    Porem estou sempre recebendo o erro "Error sending request: No valid RADIUS responses received"

    Bem, coisas que já confirmei:

    1- IP configurado no pfsense é o mesmo do meu servidor Radius.
    2- A porta usada está correta.
    3- A senha também está correta.

    Bem, vou colocar algumas imagens em anexo caso alguém possa me ajudar.
















  • configurei o meu seguindo o mesmo tuto.. a unica diferenca do seu é que utilizo vlan, na autenticacao usei mschapv1



  • @Lucas:

    configurei o meu seguindo o mesmo tuto.. a unica diferenca do seu é que utilizo vlan, na autenticacao usei mschapv1

    Testei o protcolo mschapv1 mas continuo com o mesmo erro. Realmente estou achando bem estranho isso. Na mesma rede possuo um outro sistema de autenticação em radius e ele funciona perfeitamente.



  • nos testes que fiz tive esse erro, estava com o ip errado no radius, coloquei o ip da lan do pfsense efuncionou.. outro ponto é a senha, pode dar erro se comecar com caracteres especias, na duvida use letras e numeros apenas..



  • Pois é, já estava utilizando o ip da LAN e senha simples. Pode me confirmar se existe alguma configuração que deve ser feita anteriormente a configuração do RADIUS no pfsense ?



  • nao que eu saiba.. eu nao precisei fazer nada…



  • Bem, vou continuar os testes. Se tiver algum resultado eu aviso.



  • Vitoria! Consegui fazer meu portal funcionar. Para isso utilizei a segunda parte deste tutorial (Pulei a parte do certificado). É basicamente o mesmo que havia feito, mas ele criou automaticamente mais uma regra do servidor Radius que acredito tenha feito tudo funcionar.

    http://www.fatofthelan.com/technical/using-windows-2008-for-radius-authentication/

    Mas agora surgiu um novo problema. Em minha rede utilizo um servidor de cache externo ao pfsense. E ele está camuflando todas as requisições que são feitas ao firewall. Bem , como é um problema diferente irei abrir um novo topico.

    Obrigado pela ajuda Lucas e até a proxima.