DDNS Showing correct WAN IP but updating with incorrect IP



  • Hi Folks,

    I've got a scenario where DDNS is showing the correct WAN address on status page but dyndns has the wrong address.

    I have a VPN running and have a Lan -> * rule pushing all traffic out over the VPN. I accept this is why it's updating dyndns to be that address however, why would the status page be showing the correct WAN address (I have the monitor interface set to WAN).

    Could I class this as a bug or misrepresentation of what is actually happening?

    I would have expected it to update DynDNS with the address shown in the DDNS status page. More so that I can select the VPN from the list if I wanted to update it with it's VPN.

    I've added a preceding rule to the firewall for the LAN IP to go out via the WAN GW and not the VPN. I will see how this works.

    I am using "2.2-ALPHA (amd64) built on Sat Aug 23 02:30:11 CDT 2014 "

    Thanks
    FB3rd



  • Nobody got an idea on this?  :-\



  • What is "correct" and what is "wrong" in the context of your problem? Give some more details. Press the "Save & Force Update" button on the DynDNS page of pfSense, what happens?



  • If I press the save and force button then it updates correctly to the same IP as show in green. Some while later, I guess there is an automated update, it is wrong again and the domain has been updated to the IP of my VPN (which is different to what is showing in green on the status page now).

    Something I have just noticed though -
    I have two dyndns records setup -  the one is set to "DynDNS (custom)" and the other "DynDNS (dynamic)" I don't know why I set them up like that, I just did. The second one works ok though and is always the correct address (WAN) while the first one, custom, is always getting itself wrong…



  • Well, got this one sorted out.  :P

    I found a router which I had plugged back in and was using as a switch which was calling dyndns.org with updates. Because it was not going through the FW rules, it was picking up the w rong gateway and hence, IP address. Disabled it and all is well….


Log in to reply