2xWAN Switching Problem



  • Hey everybody! There is no rush on this so if someone who is supporting a business needs help, please answer their questions first.

    Backstory :
    I have a ~1Mbps EVDO connection that is not very reliable (it's Sprint, but it is an unlimited modem data plan and there is no other ISPs in my area). Obviously Xbox and Netflix doesn't do so well with this, and with 15 devices on my network things can get slow. I have a cell phone with ~10Mbps LTE with unlimited data running a hotspot which allows me to play online.

    The Goal :
    Have all traffic run through the modem until I turn on my hotspot, then route everything through it. Then when the hotspot is disabled, have everything fall back to the modem. Then re-add squid caching (I removed it because I wanted to make sure everything else was working first)

    The Problem :
    Me!  :P  But besides that; When the hotspot is turned on everything in the house is fast and wonderful after auto switching. When I turn it off there is no internet connection, and when I manually change the rules to push through the modem things run REALLY slow and I receive random DNS errors. Eventually this does clear up, but leaves me with just one WAN.

    The Setup :
    PFSense 2.1.5 (problem started in 2.1.4) running in Virtual Box
    ~1Mbps EVDO (WAN) bridged to an NDIS that connects to the modem on the host OS
    ~10Mbps LTE (WAN2) that connects to a TP-Link travel router in client mode through a bridged adapter on the host OS
    DNS Servers : 127.0.0.1; 208.67.222.222; 208.67.220.220 (both on WAN)
    WAN  Monitor IP : From DHCP
    WAN2 Monitor IP : My Phone

    I have two gateway groups I have played around with. One that places the faster connection on tier1 and the slower on teir2. Then tried one running on the same tier but with different weights.

    Any ideas would be appreciated. Again no hurry on this. :)



  • It's amazing how typing out everything helps to focus your thoughts.

    I realized that on the gateway status page WAN has ALWAYS been reported as down. It has never been a problem since it was the only connection and I think PFSense still sent traffic through it. I changed the monitor IP to Google Public DNS and now it is reporting as up (with a latency warning of course).

    I don't have time to test this out right now as I have other IT job related things to do, but I am hopeful that this has been my problem. Will update later today with what happens.



  • Yep, the problem was with WAN being detected as down. After changing the monitor IP to an outside source, WAN was detected as up and PFSense would automatically (and very quickly) switch traffic back to WAN when WAN2 went down.

    It looks like PFSense will try to push traffic even when it does not detect a live gateway. So when it detected both gateways down it would try pushing traffic through the higher tiered WAN2.

    I have solved my own problem. Though that is good it has denied me of any wisdom you guys could have given. But this won't be the last problem I will run into so until next time  ;D

    FYI
    Sprint runs some heavy NAT on all their devices. They use a wide range of IPs between your phone\modem and the internet. I found this out one day when I was trying to forward ports through my phone. The app I was using was reporting an odd IP that I did not recognize as Sprint's. A quick search online told me the IP belongs to the CIA. After a heart attack and some more digging I found that Sprint uses this range as part of their internal routing.


Log in to reply