BUG: Disabling static routes makes pfSense boot very, very slow!



  • Hi

    For some month I have had a bunch of IPv6 routes (read: about 60) that are visible from my LAN interface.
    So to say I have some external gateways with IPv6 subnets that are connected to my pfSense LAN. Some subnets are /56 and some are /60.
    Each of these gateways have their own gateway IP with link to my pfSense LAN. However far from all subnets are being used and therefore a lot of these gateway IPs are not live/active!
    It has worked fine all along. Also during reboot where the router boots up nice and quick!

    Recently I decided that I currently do not need all of these routes, so I have (for now) disabled about 11 of them, but I was planning to disable more.
    pfSense -> System -> Routing -> Routes -> edit a route/"Disable this static route"

    After this change pfSense takes several minutes (perhaps 10 minutes) to boot. That happens also on subsequent boots.
    (I have to measure again a couple of times if it has interest to someone to know exact home many minutes or e.g. how this delay may vary on subsequent boots.)
    This very long boot time also means that services like DHCP and DNS are not starting up until after this very long delay.

    The network looks like this:

    Internet |–-| WAN              LAN|------|WAN-gateway  router1        Subnet 1|
                      |            My            |------|WAN-gateway  router2        Subnet 2|
                      |        pfSense        |------|WAN-gateway  router3        Subnet 3|
                      ...        router        ...    ...                                                    ...
                      ...                          ... /some disabled routes/  ...                    ... 
                      |                            |--/disabled route/--|WAN-gateway  router n-2  Subnet n-2|
                      |                            |--/disabled route/--|WAN-gateway  router n-1  Subnet n-1|
                      |                            |--/disabled route/--|WAN-gateway  router n    Subnet n|

    Now, if I re-enable those disabled routes then pfSense starts to boot quick again.

    Of course I could "just" delete those routes (and external gateway-references) in pfSense. But it is just much less work simply to disable a static route than to remove and afterwards add some of those routes (and external gateway-references) again when needed.
    Besides that it is likely that someone else is bumping into this issue, even though he/she might not have to disable as many routes as I have tried to.

    Has anyone else experienced this strange behavior?

    In the xml configuration file the only difference between the ordinary enabled routes and the disabled ones are the "disabled" tag:```
    <disabled></disabled>

    
    I would consider it as a bug, but I would like your opinion or experiences before I go filing a bug report!
    I might have done something wrong in disabling the static routes, but I would then like to know what in that case. :-)
    
    Tested on both a i386 normal installation as well as NanoBSD amd64\. Both running pfSense 2.1.5.
    I also noticed this behavior on pfSense 2.1.4 i386 normal installation, but at that time I did not know it was because of the disabled static routes.
    
    Thanks
    
    - Anders

Log in to reply